Support » Plugins and Hacks » All language text appearing on listings

All language text appearing on listings

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem on my website. All languages appear in the title on the homepage. It looks very messy.

    What to do??


    I found someone else with the same problem. It can be a plugin that does not work with qtranslate. Deactivate all your plugins. Activate qtranslate and look if it’s working now. Now reactivate every plugin one by one so you can look which plugin doesn’t work with qtranslate. Hope it helps.

    Best regards,

    Hola Miguel y buenas noches,

    Thank you for that, I will try that tomorrow. The other thing that I might do is as we are using WP Casa for the site, there is a PolyLang for WP Casa plug-in so I may give that a try.

    I had another issue as well within WP Casa, properties are not displaying in either price ascending or descending order on display of property-type and WP Casa seem to think that it is qTranslate that is causing that!

    Pues, mañana por la mañana, ¡otra vez!

    Gracias y un saludo


    Well, that one is solved.

    I had tried deactivating other plug-ins but none seemed to work. However, after spending a lot of time setting up a new site with the WPML plug-in, I tried again.

    I deactivated the qTranslate Slug plug-in and the texts are now separated in their appropriate places.

    The only remaining bug that I have now, is that entries in the Standard Features area of property listings (where you can put text in all languages with HTML separators <!–:es–>Sí<!–:–><!–:en–>Yes<!–:–><!–:fr–>Oui<!–:–><!–:de–>Ja<!–:–> etc.) they display as SíYesOuiJa rather than each on it’s own property.

    Hope this helps others!


    I have the same problem with page titles showing all the languages like in your case <!–:es–>Sí<!–:–><!–:en–>Yes<!–:–><!–:fr–>Oui<!–:–><!–:de–>Ja<!–:–> etc.)

    it seems it was a theme problem in my case.
    the title of the page was echoing esc_attr( $post->post_title ) instead of <?php the_title(); ?>.
    maybe this is the cause in your case too.

    Hi there! I’ve got a problem incorporating qtranslate plugin with your theme. I’ve got three languages (en,de,ru) and everything works fine except agents. There ARE three fields for the agent name in agent editing interface. But when filled in, the “Choose an Agent” and “Choose another Agent (Optional)” dropdowns showed all three values in each line (with qtranslate <–:xx–> markup in source code). See the screenshots below:

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘All language text appearing on listings’ is closed to new replies.