Support » Plugin: qTranslate X » "All In One WP Security & Firewall" & qTranslate-X

  • Resolved giuliano

    (@lotrek)


    Dear team,

    in my WP 4.1.1 I installed “All In One WP Security & Firewall” together with qTranslate-X (latest versions).
    Then I activated the AIO Security feature called Brute Force Prevention, i.e. it changes the /wp-admin URL to a new one.

    So instead of the default URL – https://www.mysite.com/wp-admin (which redirects to https://www.mysite.com/wp-login.php to log-in) the security plugin would let you to access from https://www.mysite.com/customurlaccess .

    But there’s an issue, when this plugin is activated together with qTranslate-X, the custom access URL is not working anymore and it returns 404 error. So I cannot log-in anymore.
    I tried to deactivate qTranslate-X and the issue is no more, the custom access works again.

    The weird thing is, in my previous experience with old “mqTranslate” this issue never showed up. It was working perfectly together with the security plugin, included the custom /wp-admin URL.

    I kindly ask you if there’s any way you can suggest me to solve this problem with qTranslate-X, or any hints you can provide. I would really like to continue using these plugins.

    Thanks in advance,
    cheers
    Giuliano

    https://wordpress.org/plugins/qtranslate-x/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author John Clause

    (@johnclause)

    I updated the list of incompatible plugins: https://qtranslatexteam.wordpress.com/incompatible/

    I am sorry, I do not think it is easily fixable. Yes, q-X is significantly different from mq-, and many other things did not work under mq-, which work now with q-X. The following article might explain the issue: https://qtranslatexteam.wordpress.com/2015/02/26/browser-redirection-based-on-language/, but I do not see an easy fix. We will have to adjust q-X for this problem in the next release or so. I guess you would have to either give up that plugin or go back to mq- for now.

    Hi John,
    I appreciated to recieve your reply, and of course I also agree about the overall improved features of qTranslate-X compared with mqTranslate.

    So I guess for now I’ll continue using your plugin together with the AIO Security I mentioned above, while keeping custom URL access deactivated.

    I’m looking forward to seeing your next release of q-Translate-X (btw the current version is 3.3), hopefully you guys will find a way to make this feature work.

    Thanks again,
    have a nice day
    Giuliano

    Plugin Author John Clause

    (@johnclause)

    I have just tried it under the latest version 3.4.1 and it worked for me, although nothing special for this plugin has been done. Could you confirm that this is now resolved?

    Thank you for your interest in this matter.
    So I updated both plugins to the latest versions, and tried to make them work together with that particular feature.
    Unfortunately it still doesn’t work on my installation. WP version is 4.1.1, it maybe could make a difference, I don’t know.

    Is there any particular settings you selected on both plugins?

    Thanks again for your time,
    cheers

    Plugin Author John Clause

    (@johnclause)

    I think I used all default settings. Try using something starting from ‘wp-‘ instead of ‘customurlaccess’, like ‘wp-customurlaccess’?

    I tried this one too, but still no luck.
    Thanks anyway for the advice.
    Have a nice time

    I have this problem too

    how can I fix it?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘"All In One WP Security & Firewall" & qTranslate-X’ is closed to new replies.