WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [All-in-one SEO] Since activation not in Google Index anymore

[Resolved] [All-in-one SEO] Since activation not in Google Index anymore

  • I am wondering what settings you would suggest for the all-in-one seo plugin. For some reason, since I activated it, my blog disappeared from the Google search results. I had all boxes checked … if I check noindex for categories and archive can it be that for some reason the robot doesn’t crawl my homepage as well?

    Hope someone can help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Check your meta robots tag (look in the browser source code) and robot.txt (if you have it) and see if you are blocking Google.

    Hi iridiax,

    thanks for your response. So I checked my browser source code and I am not blocking it by robots tags. I am only blocking my pages (e.g. url/about) but that is how i wanted it.
    But I guess the problem is my robots.txt. My robots.txt says:

    User-agent: *
    Disallow:

    The thing is that I don’t even have a robots.txt. Or at least I have never created on.

    Sign up for Google Webmaster Tools, verify your site, and then wait a few days for Google to visit and see if it reports any problems.

    http://www.google.com/webmasters/tools/

    Also check your site in Google with a site search: site:yoursite.com

    Hi iridiax,

    thanks for your response. So my site re-appeared in the search results. I disabled and enabled the All-in-one plugin again … but I am not sure if there is actually a correlation.

    Anyway, I registered for webmaster a while ago and the only crawling errors I get is for the pages that I added a noindex, noarchiv to. I guess that is normal, right? Although I am surprised that it gives Google a 404 … the pages do exist but are just not supposed to be crawled.

    Do you know anything about that or is that normal?

    Thanks iridiax again for your help!

    Google can be very strange sometimes, and new sites can drop in and out of the index temporarily as different Google data centers update (it happened to my site when it was new). My number of indexed pages also fluctuates even though my site is well-established.

    Are the noindex/noarchive pages in Google’s index? They shouldn’t be and shouldn’t generate a 404.

    Yes! That’s the weird thing … some of them appear in the search results. I have to say that I added the noindex, noarchive a little later so they might have been crawled right at the beginning. But I still think that if I then add the meta tags they should dissappear again, right?

    But I still think that if I then add the meta tags they should dissappear again, right?

    I would think so, but check here:

    http://www.google.com/support/webmasters/bin/topic.py?topic=20667

    Blocking with robots.txt is the most certain way to keep search engines away, but noindex usually works well too.

    Hi iridiax,

    yeah, I already read those information. Sometimes I feel its harder to get your sites out of the search results than in. 😀

    I guess I will wait a little and see what happens … I mean under normal circumstances everything should work out with noindex, noarchive. But I definetely take a look into robots.txt!

    there’s a handy plugin too for robots.txt, called
    PC Robots.txt, which can be found here:
    http://petercoughlin.com/robotstxt-wordpress-plugin

    Using this one as well as the all-in-one-seo and no probs from either together.

    Thanks rsciw, I will look into that!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [All-in-one SEO] Since activation not in Google Index anymore’ is closed to new replies.
Skip to toolbar