Support » Plugins » All-In-One-SEO plugin not working on version 2.7

  • Hi there,
    I recently backed up and moved my blog to a different location. In the process I decided to download and install the new 2.7 version. Most of the Plugins I use don’t work, although I can survive without some of them, the All-In-One SEO Plugin is one a really need, does anyone know when there will be an update to make it compatible?

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’m using it now without any problems. What is the problem that your having it might be related to something else.

    I also get an error when trying to load this in WP 2.7:

    Installing Plugin: All in One SEO Pack 1.4.6.15

    Downloading plugin package from http://downloads.wordpress.org/plugin/all-in-one-seo-pack.zip

    Unpacking the plugin package

    Fatal error: Cannot redeclare class pclzip in /homepages/12/d175634547/htdocs/blog/wp-admin/includes/class-pclzip.php on line 171

    I’ve had numerous problems like this with plugins on WP 2.7, including WP-sticky, and Twitme.

    Matt

    I’m also using AIOSEO with 2.7 without a problem. Sounds like your error when attempting to activate AIOSEO is most likely due to incompatibility with another one of your plugins that is also calling the pclzip libraries.

    Try deactivating all your plugins (except for Akismet if you’re using it) and then activate AIOSEO. If it activates with no problem then reactivate your other plugins one by one. When you activate the conflicting plugin you should get another error. Basic troubleshooting and all that.

    WP-Sticky is no longer needed since the function is already built into 2.7 (in the publishing module in TinyMCE and the “Quick Edit” feature for posts.

    For Twitme, check the 2.7 plugin compatibility list to see if it’s listed and what the problem might be and there also might be similar compatible plugin listed there as well. I know there are other similar plugins for Twitter that are compatible with 2.7. Use 2.7’s “Add New” feature under “Plugins” to search one out.

    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/tamildev/public_html/xxxxxx/blog/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/tamildev/public_html/xxxxxx/blog/wp-admin/includes/class-pclzip.php on line 5498

    SAME PROBLEM 🙁

    hey mariocon, are you using PHP Speedy plugin?

    It came out that it is conflicting with All in One Seo on my 2.7 wp blog.

    I’ve contact php speedy developer for that.

    SEO plugin in 2.7 is causing my site (domain replaced with *) a huge # of errors like:

    PHP Warning: error_log(/home/*/public_html/blog/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.log) [function.error-log]: failed to open stream: Permission denied in /*/harmony/public_html/blog/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 1210

    I’ll check out line 1210. Maybe I need to change a permission? It worked before 2.7 I think.

    Hi Friends,

    Mine is godaddy server. All in one SEO pack is not working for me.

    I installed wordpress from version 2.3 to 2.7
    I installed SEO pack from version 1.2 to 1.4.x.x

    I tried 20 combinations with all the above versions.

    But nothing worked for me…

    can you help me in make it work for me fo godaddy sever /

    Thanks and Regards

    Ranga
    [sig moderated]

    I recently upgraded to 2.7 and All in one SEO is not working for me. I’m wondering if it has something to do with the Custom Fields? It is working on the first page but not on any secondary pages.

    Any progress?

    I’m getting the same error as mirizon. Except in my case it’s complaining about like 1212. I’ve been running WP2.7 for some time now and decided to upgrade the plugin to 1.4.7. That’s when the trouble began.

    Did anyone have this and has anyone figured out the solution?

    rychag: chmod -R 777 your wp-content.

    If the plugin is working without any errors, here’s what I’ve found.

    It works fine for posts and pages, just not the home page.

    Go to the All-In-One options under Settings and fill in your home page title, description, and keywords from there.

    rychag, I was getting the same error as you. I found the solution was to only CHMOD the All-in-one plugin folder to 755 (or 777 if that doesn’t work), as opposed to Alex’s solution of chmodding the whole wp-content folder to 777.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘All-In-One-SEO plugin not working on version 2.7’ is closed to new replies.