Support » Plugin: All in One SEO Pack » All in One SEO Meta tags not showing up

Viewing 15 replies - 1 through 15 (of 18 total)
  • I am experiencing the same thing on all pages. The META description is not showing up.

    Plugin Contributor Peter Baylies

    (@pbaylies)

    rlichtenstein,

    What are your settings in Settings -> Reading for this? Is your home page set up to display a static page, or latest posts?

    mcolm83,

    It sounds like you have a different problem, so you might want to start a new thread here. Also check to see if you might be having a conflict with another plugin or with your theme.

    It’s on all pages for me, too, not just the homepage, so your advice to mcolm83 probably applies. How should I proceed from here? Would deactivating the other plugins show me if that’s where the conflict is, or would I have to delete them and reinstall them? Is there something specific I can look for in the theme code?

    Plugin Contributor Peter Baylies

    (@pbaylies)

    rlichtenstein,

    Yes, deactivating plugins to test this is fine. For testing the theme, you can switch to one of the default themes that come with WordPress such as Twenty Eleven or Twenty Twelve. If this is a live site, you might want to take a backup and/or test on a development site as well, if you have one.

    Yep, I deactivated the Akismet plugin and All in One SEO started working. Then I updated and reactivated Akismet and it’s still working. Glad it turned out to be an easy fix. Thanks so much!

    Oh actually this only solves the problem for the meta description. The keywords still aren’t working, or rather, only the first out of several is showing up.

    Plugin Contributor Peter Baylies

    (@pbaylies)

    rlichtenstein,

    That’s strange behavior. Are you on a singular page, and are they separated by commas? On the plus side, meta keywords aren’t that useful these days.

    They are separated by commas. What do you mean by a singular page? This information is only for the homepage if that what you mean.

    Plugin Contributor Peter Baylies

    (@pbaylies)

    If it’s the “Home Keywords (comma separated)” setting, then yes, those should all show up on the home page.

    I was working from the homepage itself, but after your comments I went to General Settings under All in One SEO on the dashboard and did it in there, too. It’s still producing the same results, though.

    Plugin Contributor Peter Baylies

    (@pbaylies)

    As I asked before, what are your settings in Settings -> Reading for this? Is your home page set up to display a static page, or latest posts?

    Static page

    Plugin Contributor Peter Baylies

    (@pbaylies)

    rlichtenstein,

    Ok, that should be set on the Home Keywords only; if those are showing up on the front page, then this is the expected behavior.

    Hi Peter,
    I have the same issue. Meta tags are not visible in the Home as well as other pages. Only title is generating.
    Please help

    Plugin Contributor Peter Baylies

    (@pbaylies)

    Hi sivaprasad,

    Please start a new discussion thread for your problem; in that thread, also let me know what version of WordPress you’re using, and what your website is, so I can take a look at it.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘All in One SEO Meta tags not showing up’ is closed to new replies.