Support » Theme: Customizr » All-In-One-SEO help

  • I am using All-In-One-SEO and the problem I am having is it set’s the main page title to my first blog page title. In Admin> Appearance> Customize> Front Page, I have it set to “Don’t show any post or page”.

    Anyone familiar with this that can help me to get it to show the title and description I set up in the plugin?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @tattooz305, the majority of SEO plugins will try to find which page has been registered as the front page in your database options with get_option(‘page_on_front’).

    When choosing “Don’t show any post or page”, no specific page is registered as front page, meaning that it won’t be found by any plugin.

    Two possible solutions to this problem :
    1) Workaround : define an empty page as your front page and then optimize its SEO options with your plugin
    2) Do it yourself : hook in the WordPress function to add your custom SEO options, for example, the site title can be modified with wp_title hook. You can also add meta tags by hooking into the wp_head hook.

    Hope this helps.

    Nikeo, thanks for replying. I kind of figured it out last night. I made a page, set it as my homepage and took the snippet to put the featured pages in the page. Problem now is the featured pages images won’t show. Will your Featured Pages Extension fix that?

    You shouldn’t need to use the extension to display your featured page on home. Just enable them from the customizer and it should be enough.

    I have it set up that way now but for some reason, the featured images still don’t show up. And yes, I have them checked. Can you have a look at my page at

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘All-In-One-SEO help’ is closed to new replies.