Support » Plugins » All in one SEO gives 404 errors

  • The All in one SEO plugin rewrites my .htaccess file leading to 404 errors. For my domains to work, I need to redirect the domain name to a specific folder in my root directory, which I do using .htaccess

    However, on enabling All in one SEO plugin, all pages except the frontpage of my blog give 404 errrors saying “the file /index.php does not exist”.

    In fact, the file does not exist in the public_html directory, but only in a sub-directory where my WordPress installation resides and I use .htaccess for this redirection.

    I hope I have been clear. Please can you help resolve the 404 errors?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Try regenerating your .htaccess file from the permalink page in the dashboard. Or if you can’t get in there, use your FTP account and delete the file. You can always write a new one.

    That’s what I’ve done and my site works fine now. I disabled All in one SEO and uploaded a new .htaccess file.

    But I’d like to be able to use the plugin as well. Any advice?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘All in one SEO gives 404 errors’ is closed to new replies.