Support » Plugin: All-in-One Event Calendar » All-in-One Event Calendar Update 1.10.11

  • Hi

    So I logged into my dashboard and I was greeted with an upgrade message:

    “All-in-One Event Calendar Update

    1.10.11 For Standard users is now available.”

    I was wondering has anyone else successfully upgraded? I don’t mean to cast assertions, its just I’ve had my fingers burnt blindly upgrading plugins in the past and was looking for some assurance its safe to upgrade.

    I read the release notes and to me it seems to imply that I need to upgrade to 1.10.11 in order to retain a working “free” version of this plugin. Is this true or have I misread what was written?

    By the way is there anyway to “dismiss” this notice?


Viewing 15 replies - 1 through 15 (of 70 total)
  • I just upgraded and advice you not to.

    In the front end it is working but in the backend it crashed my plugin.php and update-core.php with this error:

    Warning: array_search() expects parameter 2 to be array, object given in /…/wp-content/plugins/all-in-one-event-calendar/all-in-one-event-calendar.php on line 160

    Fatal error: Cannot use object of type stdClass as array in /…/wp-content/plugins/all-in-one-event-calendar/all-in-one-event-calendar.php on line 160

    I still can add/update events and the frontend is ok.

    As I use the standard version I posted a question at timely forum. Waiting for their reply:

    I did an upgrade 30 min ago and found out posterboard is not working.
    Otherwise, everything seems to be correct.
    From 1.10.9-standard to 1.10.11-standard.

    Looking for a solution now.

    I commented the line 160 in all-in-one-event-calendar.php and now it is working.

    (The only issue is that the google and twitter icons disapeared)

    I encountered the same problem today also when I got a notice for the update. Updated it and couldn’t enter “Installed Plugins” or core update section because I got the same fatal error as you guys.

    After commenting out line 160, it works and the update notice went away. I didn’t notice the icons disappearing though.

    Same thing happened to me. Interestingly, the line 160 error that crashed my plugins.php only happened after I tried to install a new (unrelated) plugin. If you don’t try to install any new plugins, then the update works fine. LOL

    This needs a fix quickly.

    Thanks for the tip – commenting out line 160 works like a charm.

    I got the same errors, but only when I tried to install Squelch Tabs and Accordians from That plugin (also) uses jQuery, which is what I thought the problem might be – a libraries conflict.

    This is with the version of ai1ec downloaded from the Timely web site yesterday.


    Somehow this update has crashed my entire wordpress site. I can no longer access my dashboard or any part of my wordpress site. I performed the automatic update. I am running 3.8.1.

    EDIT: I renamed the plugin folder, manually reinstalled All-In-One, and my site is back up, but now I get a fatal error when trying to activate the plugin. Commenting out line 160 didn’t seem to help. Any ideas on what I can do? I don’t want to lose all of my events.


    Did you comment the line 160 in all-in-one-event-calendar.php?


    Paste the fatal error here so we can see what’s happening…

    How do I see the details on the error? It just says: Plugin could not be activated because it triggered a fatal error.

    @brg Web

    Yes, I did (not that one should), and it’s now working. My event categories disappeared, but this could be WordPress, as I my event categories and post categories seem to be appearing in each other’s lists. Luckily I’ve only just installed it, so there few events in there yet. Lucky too that it’s for an in-house site. But with all the unanswered support questions I’m wondering why I rejected CalPress…


    Ok putting comments “// ” on the 160 line worked for me also and now I can get access to the backend Plugin Tool…. thanks .

    I can’t believe they don’t do more testing before they put out an update. You would think with the following they have that it should be important to put out clean updates.

    Upgraded to 1.10.11-standard was the biggest mistake EVER!

    It’s screwed up ALL of my dates and times. My mistake was NOT reading the release information! NEVER AGAIN will I trust any updates unless I read and study the release info and understand the impact.

    First of all, who the hell changes database properties. Time Stamp properties from a datetime to an integer.

    Now, all views of my calendar views (calendar, poster board and agendas are all affected. I’m still learning PHP, but I understand data, databases. It’s too late to roll back to a restored version as it’s been a few days and I do NOT want to lose any other updates of work by other people.

    So, is that a fix, a patch that will fix what appears to be a time zone difference? It appears the update didn’t include the link to the WordPress Default Time zone (for us, it’s Los Angeles aka UTC-8

    I upgraded manually. Then on activation received this message:
    The plugin generated xxxx characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    I deactivated plugin and reactivated and no more error messages.
    It now appears to work OK on this site.

    Next same thing on one other site.
    There must be some error in the code!

    Don’t know about WordPress 3.81
    Don’t want to update my other sites

    Hi, I did have the same problem after I did updated the plugin. Every time I was trying to add a new plugin I did get that message:

    Warning: array_search() expects parameter 2 to be array, object given in /.../wp-content/plugins/all-in-one-event-calendar/all-in-one-event-calendar.php on line 160
    Fatal error: Cannot use object of type stdClass as array in /.../wp-content/plugins/all-in-one-event-calendar/all-in-one-event-calendar.php on line 160

    I did take away the new plugin manually and log out from the site and log in again than I deactivated the All-in-One Event Calendar and reactiveted again and now I can add new plugins without any problems.
    I hope it will work for You as well.

Viewing 15 replies - 1 through 15 (of 70 total)
  • The topic ‘All-in-One Event Calendar Update 1.10.11’ is closed to new replies.