[resolved] All images on new sub-site getting 403 forbidden errors (16 posts)

  1. erikajurney
    Posted 5 years ago #

    I have a main site: tryhandmade.com
    And a sub-site: gallery.tryhandmade.com

    tryhandmade has been around for a while and I recently converted it to be the main site of a multisite network.

    The gallery site used to be a standalone, but I'm (trying to) bring it under the main umbrella. I've imported all the posts, but all the image files are getting 403 forbidden errors. I'm thinking that this is a problem with my htaccess file? Or gremlins? Here's the very first part of my htaccess:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    The rest of htaccess is all the stuff needed for W3 total cache.

    Here's an example of a file which gets a 403:

    This is where it should go, but doesn't:

    I hope I haven't left out any important details... Anyone have any brilliant ideas? I'm all out.

    Thanks very much,

  2. Hi erica! ;)

    The images should physically be at:


    ipstenu had some fun doing this but lucky for us, wrote it all down. Now if only *I* had saved that link in my handy file...

  3. erikajurney
    Posted 5 years ago #

    Hey Andrea - I was hoping you'd stop by!

    The image really is here:
    (blog ID is 10)

    If you find the notes, I'd love to know the solution - it is driving me crazy!


  4. "Forbidden

    You don't have permission to access /files/2010/09/CIMG32943.jpg on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

    Is what I get when trying to access the URL of what it *should* be.

    (the notes I was looking for were here, btw http://code.ipstenu.org/moving-your-images-for-multisite/)

    So, in this case it looks like the rewrite rules are actually... rewriting.. for some reason.

    And the blog permalinks are fine? I know you're in maintenance mode...

  5. And the part where you;re getting http://gallery.tryhandmade.com/wp-includes/ms-files.php?file=/2010/09/CIMG32943.jpg means it;s doing it internally on the wordpress end, but the htaccess part is failing.

  6. erikajurney
    Posted 5 years ago #

    (I took it out of maintenance and the problem is still there.)

    Is there some setting on my end that could be not allowing rewrites in htaccess?

  7. Turn off the cache plugin for a test? W3 total cache should be turned on per site, btw, not as network , iirc.

  8. erikajurney
    Posted 5 years ago #

    Hmm, cache off, still no joy...

  9. Bugger. Worked for someone else!

    You cleaned out the htaccess to just the standard stuff when you turned off the plugin?

  10. erikajurney
    Posted 5 years ago #

    Whoops, I hadn't taken the cache stuff out of htaccess, but I just did that (and restarted apache just for a little je ne sais quoi) but still 403...

  11. Grr! There's no reason for that error. There isn't a files folder created there, right? And no hotlink protection anywhere on the server?

  12. erikajurney
    Posted 5 years ago #

    There *is* a files folder and it has all my uploads in it.


    No hotlink protection, though.

  13. Right, but not ../tryhandmade/files :)

  14. erikajurney
    Posted 5 years ago #


    No freaking idea why there was a tryhandmade/files, but it was there (with a date from 3 months ago, so who knows why).

    So glad this was a stupid mistake on my part and not some sort of inscrutable problem with my hosting or something...

    Thank you so much!

  15. Wow... That was a total shot in the dark. Huzzah!

  16. High fives! :D

    (i went to bed, sorry)

Topic Closed

This topic has been closed to new replies.

About this Topic