WordPress.org

Forums

Easy FancyBox
[resolved] All images not being tagged by Easy FancyBox (11 posts)

  1. Xfactory
    Member
    Posted 3 years ago #

    I'm unable to get Easy Fancy Box to work on all existing images in my blog. I've gone though the help to verify that all is working. There is one area of concern which is the following paragraph written on Easy FancyBox page;

    # Make sure that thumbnail images are linked directly to their larger counterpart, not to a dynamic WordPress page that includes the larger image. This means when you insert an image in your posts or pages, you need to select File URL at the Link option instead of Page URL. You’ll have to manually edit your old posts if you have always inserted images with Page URL before, FancyBox cannot do this for you.

    I use Link URL, here is a link to a older digital painting post I had posted demonstrating that Easy FancyBox is not working.

  2. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    I'm sorry to say it, but you have got yourself a bit of a mess there with four lightbox extensions (prettyPhoto, FancyBox, Lightbox and Piro_Box) running at the same time. You need to disable them all except one (choose the one you prefer)

    Then the second step is finding out why the main jQuery library gets loaded TWICE (the second time an older version, but from the Google CDN) on your site. I suspect it is the Kino Event Calendar plugin.

    Disable that too (temporarily) and the lightbox effect should work...

    Then contact the Kino Event Calendar plugin devs and ask them to start using the official wp_enqueue_script() way of including the jQuery library... Or edit the plugin options or files yourself to achieve the same thing ;)

  3. Xfactory
    Member
    Posted 3 years ago #

    I have disabled all the extra lightbox extensions. When I trigger the image in the link given in my original message, the image doesn't load ? Why is there a white box in the top left hand corner ?

  4. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Looking quickly, still see prettyPhoto and Lightbox2 active. But the biggest problem is the fact that there are two versions of the main jQuery library loaded. It seems your theme is doing the second one...

    <script type="text/javascript" src="http://www.thecreativesheep.ca/bio/wp-content/themes/Bio_3D_Design/includes/jquery-1.4.2.min.js"></script>

    It really needs to NOT be hard coded in header.php like that.

  5. Xfactory
    Member
    Posted 3 years ago #

    I disabled all those fancy image/player loaders. When I removed the line you specified in the theme, it broke the theme, but more importantly EasyFancyBox didn't work !

  6. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    Your theme seems to have no footer.php. Or at least it is not loaded. The source is missing closing </body></html> tags. And there is no <?php wp_footer(); ?> being called...

    You need to fix that theme. If it has no footer.php, create one with at least the following code:

    <?php wp_footer(); ?>
    </body>
    </html>

    It will probably need some closing </div> tags too but I'll leave that up to you to find that out. Use the service http://validator.w3.org/ to learn what your source is missing.

  7. Xfactory
    Member
    Posted 3 years ago #

    I constructed half of the theme someone else did the PHP work and I don't think I can get a hold of them no longer, is this easy to add what you are mentioning ?

  8. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    It depends on the theme and how it is constructed...

    Meanwhile, there may be a quick workaround to get you up and running without fixing the real problems: Set transitions to "Fade" on Settings >> Media in the FancyBox Images section.

  9. Xfactory
    Member
    Posted 3 years ago #

    The suggestion you gave worked.

  10. Xfactory
    Member
    Posted 3 years ago #

    RavanH can you contact me via email. Lost your contact info.

  11. RavanH
    Member
    Plugin Author

    Posted 3 years ago #

    I've sent you an e-mail... Or you can contact me on http://4visions.nl/en/contact/ :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic