Support » Plugin: MC4WP: Mailchimp for WordPress » All images blocked by MC4WP

  • Resolved TStone

    (@tstone)


    Hello,

    Since a week back, no images have been shown on the site. Have taken forever to find the bug – which turned out to be the following code in a .htaccess file in the uploads directory:

    # MC4WP Start
    <Files mc4wp-debug-log.php>
    deny from all
    </Files>
    # MC4WP End

    If I delete that code, the site works again… for a short time, then the offending code is back again.

    Please, fix this!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Lap

    (@lapzor)

    ​Thanks for letting me know. I will ask Danny to look into this.
    Maybe your server doesn’t support the <Files> command in htaccess and you need a way to turn this feature off. Will get back to you.

    Plugin Author Danny van Kooten

    (@dvankooten)

    Hi @tstone,

    That is really strange, can you please confirm whether you are on version 4.7.2 of the plugin (and not 4.7.1 specifically)?

    Also, is the line # MC4WP Start on its own line or is it appended to the end of another line that was already there? If so, please move it to its own line and things should work as expected.

    Alternatively, you can trick the plugin into not re-adding the line by deleting everything except the # MC4WP Start line.

    Let us know please.

    I ran into the same problem which caused all uploaded content to no longer be reachable. When I checked the apache error log I saw tons of messages with the following:

    /var/www/html/wp-content/uploads/.htaccess: deny not allowed here

    I removed the .htaccess file and things worked properly again (I also removed the debug php file that mc4wp put in the uploads directory).

    I’m running WP version 5.3, MC4WP version 4.7.3, apache version 2.4.18

    Looks like your htaccess file won’t work with apache 2.4? https://htaccessbook.com/access-control-apache-2-4/

    Plugin Contributor Lap

    (@lapzor)

    Thanks for reporting the issue. I’ve created a bug report here:

    I’ve reported it to Danny he will look into this shortly.

    https://github.com/ibericode/mailchimp-for-wordpress/issues/663

    Hope that helps. If you have any questions, please let me know!

    Plugin Author Danny van Kooten

    (@dvankooten)

    Thank you @whaleyr – we’ve fixed this in the development version of the plugin by checking for the Apache version. We’ll be pushing out an update for this soon!

    I had the same issue with all images giving a 500 server error and would not appear on the site. The only solution that I could find was to remove the .htaccess files your plugin created in the /uploads root directory.

    I had the same problem and it took a while to find the cause as turning the plugin off did not solve it. Have you fixed this and released an update yet?

    Thank you

    Tamsin

    I have now decided to remove the plugin and use an alternative. Please let me know if there are any files or settings connected to the plugin that might remain after deletion so I can check for them, thank you.

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    @tamsin-carter,

    This issue was fixed a while back. Can you describe what exact issue you were facing now?

    On the site with the MC4WP plugin active we found that none of the images from the uploads folder (most of the site’s images) were showing on the site. They were not showing on the front end, or in the media library. If you tried to go to the image link or attachment page it would say ‘internal server error’. The apache 2 log showed many instances of permission denied.

    This happened twice. The first time I restored a recent backup of the uploads folder and that resolved the issue but then it happened again a week or so later.

    This last time I noticed that I could get the image to load in the ‘edit’ window of the image in media library but they still weren’t showing anywhere else. This affected pdfs in the media library too.

    I hope that helps and I am happy to answer other questions if you have them to help you resolve this. I have removed the plugin from our site and am using a woo commerce mailchimp plugin instead which is fine.

    Tamsin

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey @tamsin-carter,

    Would you be willing to try our plugin again?

    Tamsin Carter

    (@tamsin-carter)

    Hi Harish

    I actually would prefer not to in this case, as it caused such a big problem and I have found another option and set it up now.

    Tamsin

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.