Support » Theme: Magazine Basic » All galleries show 'undefined' error/broken image link when photos clicked

  • Resolved tararebeka

    (@tararebeka)


    Each post that has a gallery – if you click on any image in the gallery, when it attempts the Lightbox transition (hope that’s the right terminology), the screen dims and rather than a larger image appearing, I get a broken link icon and the word ‘undefined.’ The left and right arrows don’t work, and clicking anywhere else on screen doesn’t return to the post. I have to use the browser’s ‘back’ button to get it to respond.

    I updated the theme, am running the most recent version of WP, have disabled all my plug-ins, tried a different browser, and still no dice. When I attempt to edit a post with a gallery, sometimes the gallery icon (the large blueish box), shrinks to a clear 20x20px box instead.

    Any help/advice would be appreciated. I’m at wit’s end. This all worked fine last week and the only change was scheduled posts posting over the weekend.

    Thanks.

    http://wordpress.org/extend/themes/magazine-basic/

Viewing 2 replies - 1 through 2 (of 2 total)
  • This is the specific error, per Safari:

    TypeError: ‘undefined’ is not a function (evaluating ‘$( ‘#page’ )
    .on( ‘click’, ‘#lightbox’, function() {
    $( this ).fadeOut();
    } )’)

    And Chrome says this:

    Uncaught TypeError: Object #<Object> has no method ‘on’ theme.js?ver=3.5.2:78
    Failed to load resource: the server responded with a status of 404 (Not Found)

    All plug-ins are deactivated.

    The site is http://www.tarakerwin.com – I’m using it to test a site for our company.

    Found a conflicting JS in the text of a widget, of all places. Glad someone was able to point me in that direction, as I never would have thought to look there.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘All galleries show 'undefined' error/broken image link when photos clicked’ is closed to new replies.