Support » Plugin: Forums - wpForo » All forum pages are 404 on multiste

  • First thank you for your nice plugin… I hope it will be the best and popular!

    Just installed WpForo, but found that it does not work. I run latest wordpress with multisite (network) and tried domain-based site and slug-based site already, but still no luck.

    I created page with slug /forum and put there “[wpforo]” shortcode (i also set wpforo to use this slug “forum”/). When i open the page, anything is displayed nicely, but clicking any of the links does not work: i see 404 page. However,

    I have no other plugins on my site. However, i noticed that your plugin option “Replace login page” makes it incompatible with popular “Maintenance” plugin, you will not be able to login if you logout with all this left enabled.

    I run nginx with fastcgi/php7.1-fpm. Could you please HELP ME as i need forum and i need really now… Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have trivial nginx configuration, and it seems it should not be the issue… I don’t think this plugin may require mod-rewrite configuration when using with apache, right?

    Plugin Contributor gVectors Team

    (@gvectors-team)

    Hi Marcus,
    mod-rewrite is required for wpForo. wpForo only has SEO permalinks, it can’t work with ?p=x mode. Please enable mod-rewrite, navigate to Settings > Permalinks and update it to /%postname%/ or so.

    As i said, i use nginx, and mod rewrite requirement was surprise for me. It is not used on nginx. It actually should not be used for your plugin. This is ridiculous, i dont want to use apache.

    I am sorry.

    Could you please provide mod-rewrite rules specially for your plugin so i can convert it to nginx config directives ?

    Plugin Contributor gVectors Team

    (@gvectors-team)

    Could you please navigate to Dashboard > Plugins admin page and Uninstall (not deactivate) wpForo? Then Delete this plugin, then search and install it again. Before this manipulation please delete all pages you’ve created for forum, make sure those are removed from trash-box too. And check the default /community/ page and Main Forum page. I need to make sure this is not other configuration issue.

    I just tried all what you said and no success. I did not even change my forums base (“community”). Only this root page works but no all other links, like:

    http://sitename.wordpress-multisite.local/community/main-forum

    :'( – No plugins enabled except maintenance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.