Support » Plugin: Kirki » All CSS output from Kirki stop working on version 3.0.26

  • Resolved Kevin Mamaqi

    (@kevinmamaqi)



    Hello,

    I updated the plugin and all the styles only work when editing on the customizer, it does not save the values or apply the default values. Just happened when I updated.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Is that with a theme you’re currently developing or a theme you downloaded from somewhere?

    Please enable WP_DEBUG and check your error log. If there’s any errors in there can you post these here?

    It is a theme I am developing and there are no errors in the error log. The only thing that does not work is the css output, but the values are stored because when I change them, save and customize again the introduced values are there. Other things such as select or checkboxes works fine.

    It is generating an empty CSS file -> localhost/wp-content/plugins/kirki/assets/css/kirki-styles.css?ver=3.0.26 – totally empty.

    Are you by any chance adding the fields inside an action?

    No, I am using require get_template_directory() . ‘/inc/customizer/footer.php’ to include them, and the following function to configure it:

    
    function my_theme_customizer_styles( $config ) {
    	return wp_parse_args( array(
    		'logo_image'   => get_template_directory_uri() . '/assets/img/logo.svg',
    		'description'  => esc_attr__( 'The theme description.', 'new_Theme' ),
    		'color_accent' => '#0091EA',
    		'color_back'   => '#FFFFFF',
    		'disable_loader' => true,
    	), $config );
    }
    add_filter( 'kirki/config', 'my_theme_customizer_styles' );
    
    • This reply was modified 6 months, 3 weeks ago by  Kevin Mamaqi.

    I’m currently working on a theme using Kirki and haven’t noticed any issues… Is your theme on github perhaps or someplace else publicly available so I can see test this and see what happens?

    I am preparing it to upload and share with you. Can I send it to you via email somewhere?

    aristath at gmail

    Hi @aristath

    I found the problem, although I don’t know if it is the expected behaviour. I was using 0.5 as step in the slider control in order to control padding with ’em’ as units. Using 1 as minimum step works.

    that’s weird… just a few minutes ago I used a slider for ems with step set to 0.001 without any issues!

    I never received your theme btw so I couldn’t check anything specific for your use-case…

    I can not use 0.5 as unit in the customizer. I sent you the theme a few minutes ago.

    Hi @aristath, Hi @kevinmamaqi,

    I have exactly the same issue.

    Here is my code:

    $args = wp_parse_args( $args, array(
    	'type'      => 'slider',
    	'section'   => $this->section,
    	'label'     => esc_attr__( 'Border Radius', 'grimlock' ),
    	'settings'  => 'button_border_radius',
    	'default'   => $this->get_default( 'button_border_radius' ),
    	'choices'   => array(
    		'min'   => 0,
    		'max'   => 10,
    		'step'  => .1,
    	),
    	'priority'  => 10,
    	'transport' => 'postMessage',
    	'output'    => $outputs,
    	'js_vars'   => $this->to_js_vars( $outputs ),
    ) );

    If I change the value of step to 1, it’s work perfectly!

    'step' => 1,

    If I change the value of step to 1.5, it doesn’t work.

    'step' => 1.5,

    So it seems that all slider fields no longer return CSS if the “step” value is a a decimal number.

    I hope this will help you in your thinking and debbuging!
    I am also available to test if there are patches coming out.

    Found the issue and fixed it (commit https://github.com/aristath/kirki/commit/543a5f3f744f0244c3fd18bd01bc31039a6336cb)
    I’m going through a couple more tickets and as soon as they are resolved as well I’ll release v3.0.27

    Ok it works perfectly after update to 3.0.27.

    Thanks a lot!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘All CSS output from Kirki stop working on version 3.0.26’ is closed to new replies.