Support » Fixing WordPress » All ” characters are replaced by «

  • Resolved calande

    (@calande)



    Hello,

    I installed the French version of WordPress yesterday. I noticed that all ” characters are replaced by «. This is weird…For instance, if I want to add timing in my articles such as 10’21”, when I publish it, it reads 10’21«
    Also, sometimes I want to use double quotes, such as for quoting, but it won’t let me do, they get replaced by the old French quote symbols, it is not even done properly, e.g. « test « instead of « test ».
    Have you stumbled upon this?
    Thank you,

    Charles.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    calande

    (@calande)

    Thank you, will try…

    I found the solution of the problem in this tutorial. In functions.php of the theme, I just had to add this snippet:
    remove_filter('the_content', 'wptexturize');
    😉

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.