Support » Plugin: WP Super Cache » All cache being cleared on any post edit

  • jciselectric

    (@jciselectric)


    I have “Clear all cache files when a post or page is published or updated.” unchecked, and yet the entire cache for my site is cleared when any user of any credential makes an update. This is problematic because I have preload mode enabled, and garbage collection in preload mode.

    https://wordpress.org/plugins/wp-super-cache/

Viewing 13 replies - 16 through 28 (of 28 total)
  • For several weeks I ran Pre load manually after making any website changes. This revealed 2 more problems:

    The number of cached files started declining immediately after every run. It took only 24-36 hours for half the cache to disappear (based on the plugin’s own stats). I had only ever checked the cache size immediately after a preload so no idea how long this has been going on.

    Even with scheduled pre-loading turned off, it still ran automatically (usually at the most inconvenient times)!

    As the plugin now seems unsupported, I looked for another caching plugin with preload and found Cache Enabler. It’s a little unnerving to have so few settings, but it seems to work. You can choose whether amending a page causes the whole cache to be rebuilt, or just the cache for that page.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    If this is happening to you please enable debugging in the plugin and monitor the debug log as this will hopefully tell you what is causing this problem.

    Don’t paste unedited entries from the debug log here as it will likely contain information about your server that shouldn’t be made public.

    No need to debug anything. It is just a bug of the plugin.

    Every edit we do in a post, all data is cleared. Several posts here about it, and people that don’t report it …. simply they don’t know it happens (because of short ttl of their WPSC settings).

    Hi Donncha,

    Thanks for your response. I have already tried using debugging but I’m afraid the log didn’t give me any clues, though I’m not very technical and had little idea what some of it meant.

    I did spend a good number of hours trying lots of setting variations but this actually seemed to reveal more problems as noted above. I’ve never even managed to get preload to run at the set interval – the time seemed to be taken from the end of one run, to the start of the next, not from start to start or end to end.

    I like the level of control in your plugin but for me it doesn’t work. I’m with MassimoD – it seems to be a problem with the plugin not with the settings.

    Hope you can fix it but meantime I have to use something else.

    Do be honest after yesterday’s update i did from 4.4.2 to 4.4.3, i can’t replicate that problem no matter what.

    I have the same issue and I just read the related threads mentioned by graphicsxp and jciselectric, especially Issues 66 and 98 on github. I see that on the latter thread Donncha O Caoimh mentions the problem being related to using a static home page whereas on the former the issue is reported to relate to CPT with rewrite set to false. I use a static homepage and can confirm this is the issue for me as when I switched to posts display instead the issue went away. I cannot comment on the validity of the CPT issue. Hoping for a fix in the next version – any comment from the author(s) about whether that is a reasonable expectation or not? Until a fixed version is issued, the code referenced earlier in the thread suits my needs (but I understand why it might not be suitable for others).

    The issue persists. I use the wp super cache preloading on 3 sites with 36,000, 14,000, 8000 posts in order, and in every site when a new post or update is done all preloaded files are being cleared. This is without setting the setting ‘clear all cache files when a post is made/updated’.

    This makes preload unusable.

    I found Preload unusable as well. Pointless.

    @mountainguy2

    If you need preload, i suggest you try WP FASTEST CACHE. Offers pre-load even in the free version and works pretty well.

    WP FC preload works a bit different, pre-loads some posts/pages every time a CRON is triggered, so it takes some time to finish.

    @mountainguy2

    You may also want to take a look at Cache Enabler which also offers preloading, with the option to refresh the whole cache or just the page/post you’ve edited. It’s worked well for me (usual disclaimer).

    Thanks! Really struggling with setting up caching that actually works.

    @mountainguy2

    If you want something that works 100%, then Comet Cache is for you.

    Set it and forget it but the Lite version has no CDN and preload.

    mojamba

    (@mojamba)

    A new version was just released that includes a fix for this issue. I haven’t tested extensively yet, but so far it does seem to have solved the problem for me.

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘All cache being cleared on any post edit’ is closed to new replies.