Support » Fixing WordPress » All admin pages went blank!

  • I recently installed WordPress, and have been having a great experience with it, however, today, for some reason that I cannot figure out, I cannot access any admin pages! Every time I attempt to login, I am greeted by a blank page, and any admin page I attempt to access comes up totally blank! please help! I hope I don’t have to start over building this site!

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’m having the same problem right now, and I have no idea why… Please help! I even tried to replace wp-login.php (the culprit) with a fresh copy from the installation ZIP, but no luck. Could it be the SQL server, or an error in the PHP interpreter, or …?

    If you’re running in a LAMP (Linux/Apache/MySQL/PHP) enviroment, ask your hosting provider for a copy of the Apache “error_log”. This will show you the fatal error which is likely to be the reason why you’re getting a blank page.

    I’m having the same problem, and I didn’t do anything to mess up the database (I don’t think).

    Everything else with the page works perfectly, but the /wp-admin doesn’t work at all; it’s just a blank white screen.

    🙁

    [Mon Jun 12 22:53:26 2006] [error] [client (deleted)] Invalid method in request log=[deleted]&pwd=[deleted]%40%216wn8&submit=Login+%C2%BB&redirect_to=wp-admin%2FGET /wp-admin/wp-admin.css HTTP/1.1

    That is the error log I got. The [deleted] and (deleted) parts contained passwords and logins (and above, the IP, obviously). Otherwise that is how it looks. Any ideas? The core functionality works fine — the blog is still up and running, but I can’t get into the admin. Should I tweak something in the PHP?

    Actually, I just checked and I’m no longer having any problems. I figured it would be a problem that would be resolved overnight — or within a few hours, but I still thought I’d check. No problems here anymore.

    I’m having that exact problem. I login to dashboard with correct user name and password, and I get a blank white screen. Same result on firefox and IE.

    I installed WordPress just a few days ago, so it’s the latest version, and all was well until today. I can get to the blog: http://www.consignedesign.com/blog/, but I can’t get to the dashboard: http://consignedesign.com/blog/wp-admin/.
    Can’t get past: http://consignedesign.com/blog/wp-login.php.

    Since it’s affecting multiple users it seems to be related to WordPress rather than my webhost.

    Can anyone offer any input?

    Thanks very much.

    Myra

    I had the same problem on Saturday after uploading the Barthelemy theme and activating it. What I did was to delete the folder from the root and everything was back to order.

    Thank you bdieu. I tried doing as you suggested and moving batavia1.5 out of the themes directory and it didn’t help. In fact now I have no nice looking theme so my blog looks awful, and I can’t get into my dashboard to activate my theme so I’m sorta stuck.

    If this many people have the same problem could there be some central cause? Does WordPress depend on anything but locally installed files?

    Or is this amount of people with this exact problem at the same time fairly standard?

    Thanks again.

    Myra

    Myrab – what if you go to http://consignedesign.com/blog/wp-admin/edit.php ?

    The main dashboard relies on pulling some RSS feeds and technorati info. If any of those are down or slow it can time you out…

    I usually just skip that and go straight to a link like above.

    Thank you so much HandySolo. I actually found the problem thanks to some archived forum material. Hope this helps someone else:

    The cause was a plugin that WordPress choked on. Apparently that’s a common cause of the white screen of death (along with bad themes as indicated in this thread).

    In my case I went into the wp-content/plugins directory and realized that the plugin I added most recently was codexsearch.php. I moved it out of the plugins directory and my dashboard started right up the next time I tried.

    So, caveat and all. Don’t upload plugins promiscuously. In fact I may swear off of them.

    Thanks again for all the help here.

    Myra

    I’m just posting a follow up that I thought would be helpful.
    I’m not trying to bump the thread or anything (hey, my problem’s resolved).

    After I discovered that the codexsearch.php plugin was the culprit and removed it, I looked at my php log (shoulda looked sooner) and it had multiple entries like this:

    “[13-Jun-2006 03:46:24] PHP Warning: Cannot modify header information – headers already sent by (output started at /big/dom/x[domain]/www/blog/wp-content/plugins/codexsearch.php:2) in /big/dom/x[domain]/www/blog/wp-rss2.php on line 8
    &
    [13-Jun-2006 19:40:11] PHP Warning: Cannot modify header information – headers already sent by (output started at /big/dom/x[domain]/www/blog/wp-content/plugins/codexsearch.php:2) in /big/dom/x[domain]/www/blog/wp-includes/pluggable-functions.php on line 325″

    So the php log was very specific and helpful, which most of you probably already know.

    Also, since I’ve tried about 15 different themes and none of them crashed my dash, I’ll editorialize that in my experience plugins are especially risky to install. Some have had problems with themes, but not me.

    Cheers,

    Myra

    “So the php log was very specific and helpful, which most of you probably already know.”

    And there is a lesson there for everyone: log files are indispensible as they often point to the exact nature of the problem.

    The php log showed a plugin that has worked perfectly in other 2.0.3 uses now made all admin blank.
    Took out the offender and admin’s back up and running.

    Thanks guys

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘All admin pages went blank!’ is closed to new replies.