Support » Plugin: Complianz | GDPR/CCPA Cookie Consent » all accepted but Captcha and instagram not load

  • Resolved maaw

    (@maaw)


    Hi,

    Even i accepted all, Google ReCaptcha and instagram feed (home page, on the first section under the slider) does not load.

    google recaptcha is on the preinscription page

    What i did wrong?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • I deleted Recaptcha and putted honeypot.

    But if you can find a solution for instagram feed… what i accept, instagram feed never work.

    Thank you

    Please see the problem on the following link : https://sandbox.paris-gaming-school.com/

    and not on this https://paris-gaming-school.com/ anymore.

    thank you.

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @maaw,

    We will have a look,

    Regards Aert

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @maaw,

    In the jquery on that page I see an error: fbq not defined. This is probably caused by a dependency: the instagram script is blocked, but some custom script which is dependent on this script not. This error also probably causes the recaptcha not to activate after consent.

    A solution could be to block this dependent script as well. Right now the scripts are concatenated with autoptimize, so I can’t really tell if it’s an isolated script or part of something else. If you temporarily deactivate autoptimize we can see the source of this script, then exclude it from the concatenation so we can separately block it.

    To block this script, you can take (part of) the URL from this script, and save it in the script center, with the domains that should be blocked before consent.

    If need need more help with this you can also contact us at https://complianz.io/support

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @maaw,

    Did the answers help you out? Let us know!

    regards Aert

    Hi,

    Thank you all for your efficient reply. Sorry for my late reply.
    I’ll check it and will back to you quickly.

    Thanks again !

    Hi again,

    thanks to your detailed answer and after disabling Autoptimize I could see in the console that it was pixelcafein that was causing this problem. I reactivate for you pixelcafein so that you can see the error.
    Should I contact pixel caffeine? Or something wrong between pixelcafein and Complianz ?

    Thank you

    • This reply was modified 6 months, 1 week ago by maaw.

    try excluding pixelcafein from JS optimization maybe?

    frank (ao dev)

    Hi,
    Thank you, i deactivated Autoptimize (and empty cache) and it’s realy between pixelcaffein and complianz. When i deactivate pixelcaffein complianz and instagram feed works fine.

    I activate again complianz and pixelcaffein for that you can see the error.

    Best regards

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @maaw,

    The frontend.js script depends on an inline script that fires some facebook code. This script is blocked because of that. As a result, the frontend.js is missing a variable.

    Can you try adding the following the the script center:
    pixel-caffeine/build/frontend.js

    in the field “URL’s from scripts you want to be blocked before the cookie warning is accepted”

    This will also block this script, preventing the error.

    Let me know if this helps!

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @maaw,

    Did this work for you? We will also test this locally, and if it works add it to the block list that is shipped with the plugin.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @maaw,

    We just tested this in a sandbox, the addition to the script center seems to work. Let me know if you have any questions about this.

    Hi,

    Thank you very much, it’s work!
    Sorry for my late reply.

    Kiss !!

    • This reply was modified 5 months, 3 weeks ago by maaw.
    • This reply was modified 5 months, 3 weeks ago by maaw.
Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.