WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
Alignment of thumbnail and title (17 posts)

  1. muzikworld
    Member
    Posted 6 months ago #

    Recently i started to use YARPP. Unfortunately i had a issue with alignment of thumbnails and text related to thumbs.

    The issue is text related to thumb is placed next to image rather then beneath it. View this Image i uploaded on twitter to get a better idea. This looks so clumsy & unprofessional.

    Secondly the text should be trimmed and restricted to few words say like first 50 words of title. So that it looks formatted and aligned irrespective of length of title.

    For now i have moved back to list based related post instead without thumbs.

    Technical specifications :

    URL : xDjPop.Org
    Wordpress Ver : 3.8
    Theme : Genesis framework
    Child theme : magazine pro

    Plugins Installed:
    Akismet
    Contact Form 7
    Genesis eNews Extended
    Google XML Sitemaps
    Simple Social Icons
    Yet Another Related Posts Plugin

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    Hi muzikworld. Your screenshot is definitely NOT the way YARPP content displays for the vast majority of users. The last time I saw something like this, the CSS was not being read, because it was password-protected for some reason.

    Would you mind activating it once again so we can take a quick look in your source code? Thanks!

  3. muzikworld
    Member
    Posted 6 months ago #

    Hello Jeff,

    I have activated it for now, you can have a look.

    Just for info : Can this be because of some parameters in .htaccess or robots.txt.

  4. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

  5. muzikworld
    Member
    Posted 6 months ago #

    But how can it be missing every time?

    I installed this plugin 4 times and had to remove it, because of same.

    its what all i have in that directory. http://s27.postimg.org/llag5pg83/Untitled2.png

    Tried reuploading files, but no effect.

  6. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    Do you have control over file permissions? It almost seems like your web server is not able to run PHP files in that /includes/ directory. If those files are indeed in the correct place (and they seem like they are), I would inquire with your hosting company as to why those PHP files aren't executing.

  7. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

  8. muzikworld
    Member
    Posted 6 months ago #

    i don't think it's the issue of file permission. As per my knowledge plugin core files just need read permission to function. So granting additional permission to execute or write won't make any difference in my case; Rather may prove security threat.

  9. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    All PHP files need to be executable, and the CSS file is a PHP file due to its dynamic nature.

  10. muzikworld
    Member
    Posted 6 months ago #

    so you suggest me to change permission to 655 of all files in /includes/ ?

  11. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    I would try setting the css.php file to 755 just to see if it makes a difference. You normally should not have to mess with permissions so I don't like recommending this but I am curious if it fixes the problem.

  12. muzikworld
    Member
    Posted 6 months ago #

    already tried :(

    it seems this problem need attention from development team.

  13. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    I would check with your hosting company. I haven't seen this issue before.

  14. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    Another user had a similar issue and found that a security plugin he was using created an .htaccess change that affected all non-image files in /wp-content. You might try turning off your other plugins to see if you have a similar issue.

  15. muzikworld
    Member
    Posted 6 months ago #

    Jeff if you don't mind, will you please name the plugin. So that i can sort out the issue here on site.

    If its related to htaccess then it may be with me too, coz i have did some tweaking in it.

  16. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    Unfortunately, the user doesn't know. It could very well be an htaccess problem, though.

  17. jeffparker
    Member
    Plugin Author

    Posted 6 months ago #

    If you still haven't resolved this, try copying what should be in the YARPP CSS file directly into your theme's CSS file.

Reply

You must log in to post.

About this Plugin

About this Topic