Support » Plugin: Alfie WP Weather » Alfie shows in widget admin but not on site

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author appcuarium

    (@appcuarium)

    Hi there,

    I’m sorry, my team is on holidays, that’s why it takes longer to respond.

    Can you paste here a link to the website, so i can look into it?

    Thanks.

    Not sure whether you’ve received this, it’s in my sent box but not here, on the thread.
    Wouldn’t like to lose Alfie, best weather widget I’ve seen.

    Hi, thanks for replying.

    The site is http://www.closdesguyons.com
    However I’ve had to deactivate the plugin because, at the same time that it stopped showing on the page all the accordions stopped closing (Goodllayers Blue Diamond).
    When I deleted Alfie they all started to work again so there is clearly a conflict between the widget and the theme although they have both co-existed since I first uploaded Alfie several weeks ago.
    If you need me to re-activate it I will do so but if you can let me know when because I don’t want to leave it on for long with the site not working properly.
    Thanks
    Brian

    Plugin Author appcuarium

    (@appcuarium)

    Hi there,

    Did you try to disable the new installed plugins? Normally, Alfie WP Weather doesn’t break installation of other plugins, but other poor written plugins break Alfie WP Weather.

    Could you reinstall the weather widget, so we can lokk into it?

    Thanks.
    The Alfie Team

    Thanks for reply. Couldn’t find anything else that broke Theme.
    I’ll reactivate it now. If it’s still caused the accordions to expand can you let me know so I can remove it when you’ve had a look at it.

    Thanks
    Brian

    Hi,
    Have reactivated and the same thing has occurred. Just the title showing from Alfie and the accordions stuck open.

    Plugin Author appcuarium

    (@appcuarium)

    Hi,

    Your server is blocking Alfie WP Weather AJAX request to Yahoo! server, where data is coming from. If you recently made changes to your server, it stopped working after that. You must allow Ajax requests to be made or the plugin will break.

    Can you disable the plugin jQuery Updater for a moment and see if it works? We see it triggers an error and we must be sure it’s not because of it.

    Regards.
    The Alfie Team

    OK, deactivated.

    Plugin Author appcuarium

    (@appcuarium)

    As you can see, the accordions are working now, and the Alfie WP Weather widget is still activated. So far we know Alfie wasn’t crashing the theme, but now the slider is gone, due to a very old version of jQuery loaded by your theme. You need to reactivate jQuery Updater and check your server settings, they’re blocking Ajax requests to another servers. After that, we can provide further assistance.

    Regards.
    The Alfie Team

    Hi,

    I’m rather mystified by this.

    I’ve entered a support request to my theme provider and I’ll wait to see what the result is from that before I do anything else. I don’t want to confuse the situation.
    The problem with jquery originated with the wp upgrade to 3.6 when slider stopped working. On using the jquery updater it replaced 1.10.2 by 1.7.0 That’s the wrong way round isn’t it?
    Anyway the slider worked and everything else seemed to upload so I left it at that. Just can’t understand with jquery updater activated why its an old version of jquery.

    Thanks
    Brian

    Plugin Author appcuarium

    (@appcuarium)

    Hi,

    Actually the latest version of WordPress has an issue referenced here. What you’ll want to do in order to make Alfie WP Weather work again is check your server settings if you recently made changes and make sure your server is allowing Ajax requests.
    Regards.
    S.

    Ok, I’ve contacted my server (bluehost)who assure me that Ajax is installed and activated. I’ve uploaded an updated theme from Goodlayers, (Blue Diamond) which, I am assured will prevent any future problems with jquery. Tried Alfie – no change. I then wondered whether it was awaiting translation from WPML so I translated all 77 threads and again no joy. When I try to upload Alfie in a sidebar I still have the same problems that I had when I first conntacted you.

    Thanks Brian

    Don’t know whether you are still following the thread but have tried Alfie again. This time it doesn’t affect the theme in anyway but it still shows just the widget title and nothing else. As I have said I don’t really want to ditch the widget because it is the best looking weather widget I’ve seen, (and the most accurate), but, if it won’t work then I’ve got no option.
    Brian

    PS. I’ve got around 32 other widgets and plugins on my site and they all work perfectly well.

    Plugin Author appcuarium

    (@appcuarium)

    Hi there and sorry for the delay ( vacations ).

    Can you activate the plugin now so we can have a look?

    Pont

    (@pont)

    Hi,

    After a week or so when it was working, it has gone again so I’m afraid I’ve taken it out of my sidebars.

    Brian

    Pont

    (@pont)

    It’s back again!!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Alfie shows in widget admin but not on site’ is closed to new replies.