Support » Plugins » Alex’s style-switcher issues running locally

  • OK, here is my situation (sorry for the long explanation, trying to be clear an concise):
    Wordpress 1.0.2
    Running on a local copy of Apache and MySQL on
    OS X Panther (10.3).
    I am doing some testing locally while I redesign my site to add in WordPress when I relaunch. I have added Alex’s style-switcher to my otherwise unmoded wp install. The list of styles appears without error in the menu bar. When I select one of the 3 alternate styles from the menu the URL shows the new style (index.php?wpstyle=dots), the page refreshes and the style remains the wp-default style.
    If I set a different default style as the readme file explains to, the new style applies fine, but again using the style-switcher menu of styles does not change the style of the page.
    In both cases the refreshed page *does* know which style should be loaded, as it grays this option. It just doesn’t apply the style to the page.
    Keying in the url with the ?wpstyle=dots (for example) does not change the style either. I’ve also checked each style.css file, and they are there as intended.
    Anybody have ANY ideas of where to start on this?
    Thanks for any ideas, I’m going to bed cause it is getting late here in the midwest of the USA. 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • I had this problem running it on Apache on a Win2K machine. Problem is the cookie not being set. For some reason, and I’m not sure if it’s Apache or not, but when running it localy, it jsut doesn’t want to set. Once I posted everything to the live site, it worked there. It’s a very odd thing. I had just challked it up to Windows, but maybe it’s an Apache thing instead. ??

    Hmm, interesting. I was wondering if it would be an Apache issue. I’ll have to see if I can find anything on Apache cookie issues when running locally.
    I’ll do some other testing too and see where it gets me.

    I had this too, same setup as rfrancis. Alex replied that the code was not designed to work locally, if i recall.
    However some other hacks i have work fine setting cookies.

    I did another search here and found a thread on this issue. It didn’ t really have a resolution, just several people acknowledging they did or did not experience the same issue. In the thread Alex said it should work locally.
    I’ve got a couple of laptops I can use to test over my network, but haven’t tried it yet.
    I’ll post back what I find.

    Still no luck. Not a big deal, I can certainly live with out it at this point. From the sounds of it it is also only an issue when run locally. Once I actually have time to develop some additional looks for my as-of-yet not launched blog I’ll look into it further.

    i had the same problem with omnisecure 3.0 under winxp.. cudn’t figure it out so i dumped the hack.. i think it’s a windows thing, not apache or anythin.. 🙁

    I’ve got all the caps stuff correct – checked it many times. Not sure where the issue is. I’ve got many bigger fish to fry than this at this point. I’ll come back to it when I’ve got a bit more time to spend and when I have more styles put together.
    Thanks to all for the help!

    Doh! The above was me.

    I’m getting no love with Alex’s 1.2-Compatible WP-Style-Switcher and WP 1.2beta. My server’s running FreeBSD/Apache and I’m getting almost exactly the same symptoms as rfrancis, with two differences:
    1. no style in the list is ever greyed-out.
    2. the cookie IS being set (to the correct value) on my computer (it shows in Firefox’s cookie manager). It must not be getting called properly.
    Also, this website is on my hosted account, not running on a local server.
    Please take a moment and look at the symptoms:
    Respond if you have any guesses or questions which might guide me in the right direction.

    running localhost xampp (
    style switcher worked on opera 7.5 but failed on firefox and IE

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Alex’s style-switcher issues running locally’ is closed to new replies.