WordPress.org

Support

Support » Plugins and Hacks » Alex King’s Share-This

Alex King’s Share-This

  • I’ve tried installing the plugin, but I can’t seem to get past a javascript error:

    Error: akst_share is not defined
    Source File: javascript:void(akst_share(’22’));
    Line: 1

    Prototype is where it should be…however, I don’t think the plugin is injecting the proper head statements to make the plugin work.

Viewing 15 replies - 1 through 15 (of 135 total)
  • icd10
    Member

    @articles

    Do you have an url?

    Alex King
    Member

    @alexkingorg

    Let me ask you to run through some standard debugging steps, then we can better identify where the problem is and fix it:

    It’s a good idea to do the following:

    1. deactivate all other plugins
    2. activate a copy of the default theme
    3. enable the plugin with the copy of the default theme

    If the plugin works properly on the default theme with no other plugins enabled, then it is likely mis-behaving on your site due to a conflict with your theme or other plugins you have enabled.

    Enable your plugins again, one by one, and see if their activation creates the breakage.

    If all works with the plugins enabled, then the problem is likely in the theme itself.

    oh yeah. sorry. This is the url. Click on any post, scroll down to the bottom of the post and click the “share this” link.

    All my links look like this:

    http://furl.net/storeIt.jsp?u=undefined&t==undefined

    Also, when you Email This, the page reads:
    OK
    The document has moved here.

    Apache/1.3.37 Server at http://www.——.com/com Port 80

    Is this normal? Or is is supposed to go to the home page automatically?

    I’ve been waiting for this plugin for a long while! I appreciate all your efforts in this!

    Way to go! Alex, you write the most useful plugins…

    Thanks!

    I am having the same error with the undefined url.

    First of all, thanks to Alex for the plugin.

    Second, when I use email-this, I’m getting the same thing the gentleman above is experiencing. I get this message:

    OK
    The document has moved here.

    I tried looking at code, but I can’t figure it out.

    My URL is http://ulyssesonline.com

    Any help is appreciated. Thanks.

    Alex has been by to reply, so it’s probable that he’s looking into the problem….

    Alex King
    Member

    @alexkingorg

    I’ve not seen anyone yet report going through the debugging steps I took the time to outline above. I don’t think it’s unreasonable to ask for a little legwork to get some from me in return. 🙂

    Share This expects there to be proper IDs on post title elements, as in the default theme:

    h2 id="post-2484"...

    This is likely the reason for the ‘undefined’ errors.

    The wp_head and wp_footer calls also need to be present in the theme (I think I noted the wp_footer one in the README, but at least one person here seems to be missing wp_head as well).

    Perhaps this is an unreasonable expectation of themes to include these calls and the IDs in a standard way. However, it is how Share This is currently written, so I guess you’ve got a choice of “fixing” your theme or “fixing” the plugin to get it working.

    cesaracardoso
    Member

    @cesaracardoso

    Only to second: got the same problem as pigizen and JeffA. Send-by-email works.

    Hello,

    Firefox and Safari (on Mac OS X) throw an error on line :

    var url = encodeURIComponent($('post-' + id).firstChild.href);

    The error is : $('post-' + id) has no properties

    It seems to be a strange javascript problem because the javascript links shows a id number….
    Its like id was not propagated in the js function.

    As I’m french the “share this” text is translated to “Partager ce texte (ou cette vidéo) ne fonctionne pas encore”

    In case you wonder the problem is the same with the original english file.

    Luc (see here)

    I have tried disabling everything and it is still not working right. I can’t figure it out. I do know that I have a theme and another plug-in that use prototype.js but they store the javascript in their own folders, which is a bad idea. It is creating quite the chaos.

    Hllo,

    I discover a source of problem for the thmes.

    The main entry div must have id="post-<?php the_ID(); ?>"
    it was not the case with simpla thm I’m using and it’s the reason why the js failed.

    Now I have the infamous “document moved here” problem when using email (but it works) but social link have an empty url value (undefined)

    Hello guys,

    I found the problem source for the social links.

    Each post must have at the H level of th title :

    id="post-<?php the_ID(); ?>"

    The problem lies in the templates.

    Some doen’t use a id="post-<?php the_ID(); ?>" at all
    Some use it in the surrounding div.

    In fact each post must be of the form :


    <div....
    <h2(or whatever value) id="post-<?php the_ID(); ?>">
    <a href="<?php the_permalink() ?>"
    rel="bookmark"
    title="Permanent Link to <?php the_title(); ?>"><?php the_title(); ?>
    </a>
    </h2>
    This doesn't solve the <em> document moved </em> problem but social links now work.

    Excellent, thanks Luc, one down one to go!

    Alex King
    Member

    @alexkingorg

    I can’t reproduce the “document moved” problem on a clean 2.0.5 install (and it doesn’t happen on my site) – can you when you go through the debugging steps?

Viewing 15 replies - 1 through 15 (of 135 total)
  • The topic ‘Alex King’s Share-This’ is closed to new replies.