WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery - WordPress Gallery Plugin » [Resolved] Albums mixed up when opened

[Resolved] Albums mixed up when opened

  • Hello!

    I am trying to use NextGen Gallery to upload image galleries and show them in different albums based on the topic. Right now I have set up a page where there I have put the NextGen Basic Compact album views to every album respectively. Right now I have 2 galleries put in the last album, and when I clink on a gallery, the images of that gallery show up on a different album view’s place (usually on the first album’s place), link here.

    I am not sure this is the right way to use the plugin, basically I would like to achieve that I am able to show galleries arranged by topics, and when an user clicks on a thumbnail of a gallery, all of the images in that category show up.

    Thank you in advance!

    Cheers,
    Balint

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author photocrati

    @photocrati

    @toth Balint BT – I would recommend only one album inserted into the page but have that album contain sub-albums and galleries as necessary to create that same look you appear to be trying to create.

    This will create an effect of clicking on a sub-album / gallery and it will replace what is being shown by the “parent-album” and will continue in a similar fashion as you navigate deeper into the album/sub-album/gallery structure.

    – Cais.

    Hello Cais! Sorry for my slow reply!

    Thank you very much for your tip, it works as it should now.

    Just an additional question. Although I didn’t had time to upload many galleries yet, but I have noticed that on the main album view on the public site (which contains all my topic-related albums), those albums that have longer names, their name doesn’t show fully, just the first 10 or so characters, and after that the 3 dots. Could you please tell me where can I set it up so the whole names are visible?

    Thank you!

    Cheers,
    Balint

    Plugin Author photocrati

    @photocrati

    @toth Balint BT – There is no specific setting in NextGEN Gallery where that character count is specified, it has more to do with several factors including but not limited to the album layout and the title length, then there is some JavaScript that gets in there and uses the ellipsis you are seeing when that criteria is met.

    I would have to get one of our developers to explain all the finer details of that as it is not obvious at a quick review of the code.

    The JavaScript being used can be found here: /products/photocrati_nextgen/modules/nextgen_basic_album/static/jquery.dotdotdot-1.5.7-packed.js

    – Cais.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Albums mixed up when opened’ is closed to new replies.
Skip to toolbar