WordPress.org

Support

Support » Requests and Feedback » Akismet really sucks now

Akismet really sucks now

  • It keeps getting worse. From the occasional spam comment getting through (I have all comments set to moderation for new users, so I get e-mails), it’s now dozens a day. There was a development version that was a bit better, but then with the latest upgrade, which I assumed had the same fixes, it’s just terrible. I keep getting the same messages about network issues, something I never had with Akismet until around a month ago.

Viewing 15 replies - 1 through 15 (of 34 total)
  • It’s not Akismet sucking, it’s spammers being more aggressive. There’s been a recent influx in all sites, WordPress, Blogger, forums, you name it, of spammers :/

    You may want to add in something like Cookies for Comments or Bad Behavior to help.

    I’ve got a CAPTCHA tool that is supposed to work with Akismet.

    And it’s not spammers being more aggressive, it’s Akismet failing. I see the messages on my Admin page. This has been happening for more than a month, and there are other post here about it.

    Akismet is a learning tool. As more spam comes in, and more people mark it as spam, it LEARNS and gets better. When new, never before seen, kinds of spam comes in, there’s a learning curve.

    CAPTCHA doesn’t work. It’s 10% effective and can be hacked. Try the two plugins I mentioned, Cookies for Comments and Bad Behavior.

    No, sorry, that’s not it. Akismet is showing that there are network errors. It’s not about learning.

    You’re talking about the Server Connectivity area on wp-admin/plugins.php?page=akismet-key-config ?

    No, I’m talking about the messages that Akismet displays above the comments list:

    Akismet has detected a problem. A server or network problem prevented Akismet from checking 1 comment. It has been temporarily held for moderation and will be automatically re-checked in 20 mins.

    I have never seen that in 4 years of running Akismet on a site.

    From some guys at Akismet:

    Unfortunately, it’s hard to tell if the problem is on Akismet’s end or your server’s end, but I’m reasonably sure that the problem wasn’t on Akismet’s end (otherwise there’d be quite a few more folks with the problem).

    If you’re still having the problem, please contact Akismet support directly at http://akismet.com/contact/

    Also, make sure you’re using 2.5.2 (the latest version).

    There’s at least one other thread (it’s hard to find more, as the search feature for the forums is limited) where others are saying they have the same problem. I’d never seen that in more than 4 years, but it started a month or so ago.

    This one: http://wordpress.org/support/topic/akismet-250-serverconnection-problem?replies=40

    Yeah, there’s SOME complaint, but not the massive amounts I’d expect to see if this was a widespread issue, even taking into account the 10% rule (10% of the people having a problem complain).

    @kirckmc –

    Best way to reach akismet.com for help is to contact us directly at akismet.com/contact/

    As I’ve mentioned on other threads, that message is something new starting with version 2.5 of the Akismet plugin. It looks for errors when communicating with akismet.com to check comments for spam. Previous versions of the plugin simply ignored any errors in communication.

    There are several reasons when your WordPress install may have had a problem reaching akismet.com. If this is only happening periodically (vs. with every comment) then the most likely reason is small hic-ups in the network connectivity of your hosting provider.

    Another thing that you can try, if you are willing to experiment a little bit, is increase the request timeout value. In 2.5.2 we increased the timeout to 15 seconds, which should be more than enough. But if communications are slow from your WP install to akismet.com, you could increase that value (perhaps 30). It is on line 145 of akismet.php.

    If increasing the timeout value does help I’d like to know.

    I’ve changed the timeout value as you suggested. I’ll let you know what happens. Is there any way to log what Akismet does?

    You can use this plugin – https://plugins.svn.wordpress.org/akismet/debug/wp-http-error-log.php – to log all of the HTTP requests made from your WP install, which will include all of the Akismet requests.

    There is also a history for each comment as well, which may provide some helpful details.

    Changing the setting to 30 seconds seems to have resolved the problem (for now). I’ll have to wait overnight and see what shows up in the morning.

    Perhaps this should be configurable from the plug-in page rather than just in the php file?

    FYI there’s independent third party monitoring of Akismet uptime here.

    Other than a 12 minute problem a couple of days ago, there have been no connectivity issues recently.

    OK, 10:18 French time, just had another one of these. And this is with the 30 second setting I changed yesterday.

    Tellyworth, it’s not about uptime, apparently, it’s about response time.

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘Akismet really sucks now’ is closed to new replies.
Skip to toolbar