WordPress.org

Forums

[resolved] Akismet problem (9 posts)

  1. graybo
    Member
    Posted 9 years ago #

    I'm running Akismet 1.12 under WordPress 1.5 and I have a problem. I've attempted reporting this problem on the development blog (my comment has been awaiting moderation for two weeks) and also emailed the developer (no reply after a week). I know from comments to my own blog that I'm not alone with this problem, so suggestions welcome.

    Akismet won’t let me review comments on the Akismet management page. When I go to the review/moderate page, I get this error message where the list of messages should be displayed:
    Fatal error: Call to undefined function: get_post() in /usr/local/psa/home/vhosts/grayblog.co.uk/httpdocs/wp-content/plugins/akismet.php on line 253
    I know that there is at least one false positive that has been caught by Akismet and I'd like to be able to approve that particular comment and clear out the trash (before the trash is automatically cleared by Akismet).

  2. graybo
    Member
    Posted 9 years ago #

    I should add that Akismet is working and blocking gazillions of spam.
    In addition, the problem occured after upgrading to 1.12 from 1.0. Prior to that it had functioned normally.

  3. graybo
    Member
    Posted 9 years ago #

    Upgrading to WP2.0 appears to have fixed this problem.

  4. Daisyhead
    Member
    Posted 9 years ago #

    I am having this same problem. Does Akismet not work with V1.5 of WP? Right now it's catching non-spam related comments and I can't get them marked as "not spam" so the comments appear on my blog.

    HELP!

  5. Daisyhead
    Member
    Posted 9 years ago #

    Btw, the error that I see is in the Akismet management screen:

    Fatal error: Call to undefined function: get_post() in /xxxxx/xxxxx/public_html/wp-content/plugins/akismet.php on line 256

    Line 256 is:

    $post = get_post($comment->comment_post_ID);

    Any help would be greatly appreciated!

  6. kbiglione
    Member
    Posted 9 years ago #

    I'm also receiving the fatal error running this plugin on 1.5. Looking for a quick fix short of upgrading.

  7. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    To use Akismet you must have WordPress version 1.5.2 or higher. Lower versions aren't supported.

  8. kbiglione
    Member
    Posted 9 years ago #

    Thanks Matt.

    That should probably be mentioned somewhere on the Akismet site.

  9. rakeshagrawal
    Member
    Posted 9 years ago #

    Would be nice if Akismet checked the WordPress version number and notified the user so that hacks like me didn't spend too much time trying to figure things out. :-)

    Upgrading from 1.5 to 1.5.2, do these instructions apply (it feels like most of these instructions apply to 1.5x --> 2.x upgrades):

    http://codex.wordpress.org/Upgrading_WordPress#Detailed_Instructions

    In particular 1) do I need to delete all of my old wordpress scripts or can I just upload all of the new files atop the old ones? 2) is there an upgrade script to be run when upgrading from 1.5 to 1.5.2? 3) are there plugins that worked under 1.5 that don't work under 1.5.2?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags