Support » Plugin: Akismet » Akismet plug-in produces White Screen of Death

  • I have been using the Akismet plug-in to blog comment spam from my blog for many years. In the last few days a new problem has occurred. When I attempt to go to my home page (http://theglitteringeye.com) I only get a white page. This does not occur when I access any other of my pages via direct link. I can access the admin dashboard.

    I have isolated the problem to Akismet. I deactivated all of my plug-ins–the problem went away. I reactivated Akismet–the problem recurred.

    My web host says that, since the plug-in is third-party, it’s not their problem.

    If I deactivate Akismet, I get several hundred comment spam per hour. If I activate Akismet, I can’t reach my home page.

    HELP!!!!!!

    https://wordpress.org/plugins/akismet/

Viewing 15 replies - 1 through 15 (of 43 total)
  • Check your error logs to find out exactly what error is taking place, and post those details here.

    I too got a fatal error when I updated to the newest version of this plugin. I have been using WP and akismet forever. This is wrong on every level. I had to go to great lengths to get this fixed and that includes having my hosting company help me which I hate as it costs me money. Fix it please. I can not update this plugin until it’s fixed.

    leftwingnutjob.net

    Warning: require_once(/home/content/43/7371043/html/wp-content/plugins/akismet/default.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/43/7371043/html/wp-includes/template.php on line 2

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/content/43/7371043/html/wp-content/plugins/akismet/default.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/43/7371043/html/wp-includes/template.php on line 2

    I’m getting the exct same errors as dusty1215, the entire site is shot right now.

    Thanks

    I had to reset my blog back a couple of days and ignore the update to fix it. Only way I found to get around the fatal error.

    How do you reset a website back a couple of days? I know that I can do this for individual pages but is there a way to do the entire website?

    Previous post:

    I’m not sure if this issue belongs here or not.

    Yesterday, my dashboard showed that I needed to install some updates. I started at the top and Akismet 2.6.0 was the first one on the list. I clicked on ‘Update Now’ and when I tried to go back to the ‘Plugin’ page, the screen goes blank. I did the same thing on a second website and the same thing happened. Any suggestions? I don’t know anything about Wordfence.

    Websites:
    http://www.naranonkc.org Twenty Eleven Theme
    http://www.naranonmidwest.org Twenty Twelve Theme

    I do not use Akismet on either site, I left it on my plugin list because I thought someday I might need to install it. I have updated it before and haven’t had any issues.

    Please let me know how I can fix this problem. I can still update pages and events but cannot pull up my ‘Plugin’ page.

    Rod

    I have the exact same problem as Rod. I wanted to upgrade to Akismet 2.6.0 and afterwards the whole plugin page turned white.

    I have no clue how to solve this. Please help out here!

    esmi

    (@esmi)

    Forum Moderator

    @skogsstjrna: If you require assistance then, as per the Forum Welcome, please post your own topic.

    It looks like they got the cart before the horse. WordPress 3.8 contains code that doesn’t play nice with the new version of Akismet. Upgrading to 3.9 fixes the issue.

    Now, if you can’t access the dashboard because akismet broke everything, you’ll have to comment out the offending code.

    Go to <root>/public_html/wp-includes/template.php and put // before line 331 to comment out require_once(ABSPATH.’public_html/wp-content/plugins/akismet/default.php’) or something similar.

    I upgraded and it deleted the code, so I’m not sure the exact code. But, I had the white screen of death, and commented out the code, then upgraded to 3.9 fixed everything.

    Hope this helps.

    Plugin Author Christopher Finke

    (@cfinke)

    jlptbootcamp: It looks like your version of WordPress was manually modified at some point; line 331 of wp-includes/template.php in 3.8 was blank. See this: https://core.trac.wordpress.org/browser/tags/3.8/src/wp-includes/template.php#L331

    Upgrading to 3.9 would indeed fix the issue, but so would reinstalling 3.8.

    Plugin Author Christopher Finke

    (@cfinke)

    DSchuler: Did you install WordPress manually, or was it an auto-install by your host? If by your host, which host are you using?

    Huh, well ain’t that something. Why would code get edited that way? I thought it looked a little strange.

    I never hack the core so some other strange force must have done it. I’m not sure why I hacker would do that though.

    All I can remember was updating askimet lately. And the latest 3.8.3 security update.

    I just attempted to update to Akismet 3.0.0. It did the download, but never activated. Now when I click on Installed Plugins I get a white screen. I can navigate to other areas of the CMS. I tried to updated to 3.9 after this happened and that too is a completely white screen. The site is up and functioning, just not the CMS. HELP!

    Plugin Author Christopher Finke

    (@cfinke)

    What other plugins do you have installed? And what theme are you using?

    Are you able to view your site’s error log? If you are, any error that mentions Akismet would be helpful in resolving this.

    I’m on WordPress 3.8.3
    Elegant Themes: Harmony (with child)
    Since I can’t see any of the installed plugins, I can’t tell you what they are.

    I honestly don’t need Akismet since this site doesn’t utilize Comments. I tried to delete the folder via FTP, but that didn’t fix the issue. I put it back.

    I was able to get into Plugins > Editor and it looks like 3.0.0 was installed:

    <?php
    /**
     * @package Akismet
     */
    /*
    Plugin Name: Akismet
    Plugin URI: http://akismet.com/
    Description: Used by millions, Akismet is quite possibly the best way in the world to <strong>protect your blog from comment and trackback spam</strong>. It keeps your site protected from spam even while you sleep. To get started: 1) Click the "Activate" link to the left of this description, 2) <a href="http://akismet.com/get/">Sign up for an Akismet API key</a>, and 3) Go to your Akismet configuration page, and save your API key.
    Version: 3.0.0
    Author: Automattic
    Author URI: http://automattic.com/wordpress-plugins/
    License: GPLv2 or later
    Text Domain: akismet
    */
    
    /*
    This program is free software; you can redistribute it and/or
    modify it under the terms of the GNU General Public License
    as published by the Free Software Foundation; either version 2
    of the License, or (at your option) any later version.
    
    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.
    
    You should have received a copy of the GNU General Public License
    along with this program; if not, write to the Free Software
    Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.
    */
    
    // Make sure we don't expose any info if called directly
    if ( !function_exists( 'add_action' ) ) {
    	echo 'Hi there!  I\'m just a plugin, not much I can do when called directly.';
    	exit;
    }
    
    define( 'AKISMET_VERSION', '3.0.0' );
    define( 'AKISMET__MINIMUM_WP_VERSION', '3.0' );
    define( 'AKISMET__PLUGIN_URL', plugin_dir_url( __FILE__ ) );
    define( 'AKISMET__PLUGIN_DIR', plugin_dir_path( __FILE__ ) );
    define( 'AKISMET_DELETE_LIMIT', 100000 );
    
    register_activation_hook( __FILE__, array( 'Akismet', 'plugin_activation' ) );
    register_deactivation_hook( __FILE__, array( 'Akismet', 'plugin_deactivation' ) );
    
    require_once( AKISMET__PLUGIN_DIR . 'class.akismet.php' );
    require_once( AKISMET__PLUGIN_DIR . 'class.akismet-widget.php' );
    
    add_action( 'init', array( 'Akismet', 'init' ) );
    
    if ( is_admin() ) {
    	require_once( AKISMET__PLUGIN_DIR . 'class.akismet-admin.php' );
    	add_action( 'init', array( 'Akismet_Admin', 'init' ) );
    }
    
    //add wrapper class around deprecated akismet functions that are referenced elsewhere
    require_once( AKISMET__PLUGIN_DIR . 'wrapper.php' );

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Akismet plug-in produces White Screen of Death’ is closed to new replies.