Support » Fixing WordPress » Akismet not working & dashboard feeds not showing…

  • I have been looking around this forum for help with my problem(s). But I haven’t found anything that has worked for me yet, so I therefore start this topic. If this has been answered allready, please point me to where!

    I’m running WP v.2.8.2. Everything (including auto updates / auto install plugins) was working smoothly before, but now I have these problems…

    – Admin Dashboard (screenshot)
    As you can see in the screenshot, all feeds and the incoming links doesn’t work.
    All of these are working on another blog I have that is running on WP 2.7.1!

    – Add New Plugins (screenshot)
    I can’t auto install new plugins (or update current ones) anymore. I get this error when I search for plugins and when I click any of the links (featured / popular / newest etc…).
    This doesn’t work on my 2.7.1 blog either, but there it gives me “An Unexpected HTTP Error occured during the API request.”

    – Akismet (screenshot)
    Akismet isn’t working any longer.

    – Scheduled Posts
    Not working anymore, I get a “Missed Schedule” message when I try. This was working earlier!

    – Auto Updating WordPress
    This was working before, this is how I got to version 2.8.2. But now when I try to update my other blog it doesn’t work.

    Downloading update from
    Download failed.
    Installation Failed

    I have tried to deactivate all of my plugins, changing the theme to default and manually re-install the 2.8.2. But nothing seems to work to fix my problems!

    What can I do to fix these problems? I’m guessing that they are all related, and that it might be something with my host… But what should I ask them if thats the sollution?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Just found out that I can’t upload images anymore either 🙁
    The other problems I can live with. But I really need the image uploader to work, as that is something I often use.

    I have tried both the “Flash uploader” and the “browser uploader” but none of them work. All I get in the media manager is the name of the image, and then just a blank space where the image is suposed to be. I looked at my ftp, and the image isn’t there!
    I also tried changing the permissions of the folder, but that didn’t help.

    I would really apreciate if someone could help me with this!

    I am also going through same problem. Amazing fact is that on several occassions everything worked fine. But most of the time I get error code wheneve request is made for external API.
    Most probably this issue arises because of the webhosting company, it is quite common with people who are hosted on shared hosting.
    Most of the time we get very high promises at very low price, from these hosting companies, they claim that everything is unlimited but they compensate the unlimited options by limiting the performance of the shared hosting server by using limiting parameters in their PHP. The host I am using is not even allowing me to see the PHP configuration so that I can find out what exactly is happening with my blog.
    Although they claim that they allow custom php.ini but even that is not working.
    I tried the core plugin and found that php http extension is not available.
    Is this the reason because of which I am getting error in akismet and http: time out error when I try to install new plugins or themes in my wordpress blog (version 2.8.4), I am also not able to install the update of word press 2.5.


    I’d like to inform you guys I went through this same exact thing WHILE I was developing my WordPress blog. I was making some posts and went to disable a plugin when I noticed I got a “500 Internal Server Error.” I figured I must of messed with something so I uploaded my backups and the same exact thing was going on. I then managed to turn the plugin back on and I could access plugins.php again. I then tried to manually install a plugin and boom, “500 Internal Server Error” happened again, but once I removed the plugin folder from wp-content/plugins I could see the page again.

    This was very weird and didn’t make sense, but it seemed whenever I messed with any plugin the plugins.php (adding folders, installing plugins anything new or different added) page would break. So then I tried to go to the plugin-install area where there was no search results or popular tags and my dashboard wouldn’t pick up any feeds, couldn’t upload images and akismet stopped working. Something was very wrong…

    I then logged into one of my other sites wp-admin logged in and the same thing was going on which led me to conclude there was no way in hell I did something (both sites effected and are on the same server), it HAD to be my host. After searching through PHP configurations and searching and searching, I happened to click on our CPANEL Fantastico link and found an abundant of these errors…

    Warning: shell_exec() has been disabled for security reasons in /tmp/cpanel_phpengine.1257856467.15804cIK2LRagZL on line 1473

    Seemed shell_exec was disabled from my hosts side accidentally, after spending about 3 hours thinking I messed up I sent my host a ticket letting them know of the error, they sent me an e-mail back saying they had fixed it and low and behold everything worked again.

    So to my knowledge it’s happening because either A.) Your host only allows 32MB of memory (was the first issue which I requested for an increase and they happily did it for me) or B.) Your host has disabled something (like the shell_exec error I mentioned, if you have cpanel click on fantastico and see if you have that error).

    If you have access to another installation of WordPress on the server then log in and check to see if it’s the same case (search, feeds and etc not working). Also check to see if there are any plugins at all installed and active, uncheck those and if it’s still messed up then it’s your hosts side.

    Also check your “WP-Settings.php” and make sure your memory limit is not set to 32MB (code is right below for example, change the 32M part to your actual memory amount). Even if your host has increased your memory if WordPress is still set to 32MB it will not go passed it (found out the hard way).

    if ( !defined('WP_MEMORY_LIMIT') )
    	define('WP_MEMORY_LIMIT', '32M');

    Sorry about the long post, but I had been trying to research this problem for a long time and couldn’t find anything and finally found something out and figured I’d inform everyone. Hope this helps because it was a pain for me to figure out.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Akismet not working & dashboard feeds not showing…’ is closed to new replies.