WordPress.org

Support

Support » Plugins and Hacks » Akismet » [Resolved] Akismet API page blank, letting all spam through

[Resolved] Akismet API page blank, letting all spam through

  • My host had some issues yesterday with their servers which sparked off all the problems I’m having now. The most major issue is Akismet suddenly stopped working. Before that, it worked awesome. Now it won’t filter any spam and it all gets sent into my comment queue or directly to my email inbox.

    When I try to click on the settings for Akismet to check the server status and re-enter my API I get a blank page. It is not the “white screen of death”, I see Akismet at the top of the page, but no content loads like it normally should. How do I fix this?

    I have tried everything so far. Disabling and enabling all plugins. Loading default wordpress template and nothing gets Akismet back.

    https://wordpress.org/plugins/akismet/

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    @esmi

    Forum Moderator

    Can you replicate the problem using the default Twenty Fourteen theme with all other plugins deactivated?

    Thanks for the response! I’ve tried that already though. I used default Twenty Twelve as well as default Twenty Fourteen themes with all plugins deactivated. At one point, I even deleted all plugins and reinstalled them all. None of that fixed the issue.

    I’ve also already checked and set my PHP limit to 64M so that wasn’t the issue. I checked the error logs in cPanel and there wasn’t anything there that would point to this problem. I really think it has something to do with my host’s downtime because everything worked perfectly before. I tried contacting them, but no response so far. I really like how Akismet works and want it back so if anyone has any ideas of what I can do on my end, I’d really appreciate it. I’m on a shared host so cPanel is the most I can access. 🙁

    I am having the exact same problem. Just activated Akismet and settings page is blank. No other errors. Turned on both php and wp_debug which were not much help (only two warnings none of them related or fatal). Any ideas?

    I found the incompatibility, hopefully this will help others in the future. I am using Slim Jetpack (with sharedaddy enabled only) and it is the cause. When I deactivate that plugin, the Akismet settings pages will show.

    Thanks Stephen S for posting your solution. I had the same Slim Jetpack plugin and when I deactivated it, the settings page showed up again.

    I don’t have that plugin but still have a blank Akismet page – and a deluge of SPAM. Running WP 3.9.1, everything bang up to date… http://www.ianwaring.com

    esmi

    @esmi

    Forum Moderator

    @ianwaring: If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else’s topic.

    Plugin Author Christopher Finke

    @cfinke

    Design Engineer at Automattic

    Marking as resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Akismet API page blank, letting all spam through’ is closed to new replies.
Skip to toolbar