Support » Plugins » Akismet and UTW both having trouble

  • As best as I can tell, these two things started happening on the same day: 1) Akismet 2.0 could no longer validate my API key, which it had been doing successfully and 2) the Ultimate Tag Warrior function to get keyword suggestions from Yahoo returns the following error:

    Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/example/public_html/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior-ajax.php on line 108
    Warning: fsockopen() [function.fsockopen]: unable to connect to in /home/example/public_html/wp-content/plugins/UltimateTagWarrior/ultimate-tag-warrior-ajax.php on line 108
    Permission denied (13)

    I have tried all the suggestions in the Akismet FAQ for what to do when your API key won’t validate–retyped it in, waited a while, and checked with my webhost.

    I told my webhost about both problems, and they said

    I checked it out after turning off the firewall rules on the server and still the issue remains. Please get back to us after checking it out with the vendor of the plugin as they will be able to debug this quickly.

    I contacted Akismet on 10-Feb through their contact form but have not heard back yet.

    I also deactivated all plugins except Akismet, and it still couldn’t validate my key.

    I don’t know much, but it seems to me that both programs are trying to access a server external to my webhost and are failing. Both plugins were working fine, UTW for weeks and Akismet for months, before the trouble started. So the problem is probably with my webhost, but I don’t know enough to tell them what to look for. Can anyone give me any clues, hints, suggestions that I can send their way? My WordPress version is 2.05. I am on a Linux server that uses Apache 1.3.37 (Unix), php 4.4.4, and mySQL 4.1.21-standard, in case it helps to know those things.

Viewing 1 replies (of 1 total)
  • It is now working again just as inexplicably as it stopped working. The only thing I have done is upload more files to the plugin directory, without activating anything new. I am not at all certain that doing so solved the problem, but offer it up “just in case.”

Viewing 1 replies (of 1 total)
  • The topic ‘Akismet and UTW both having trouble’ is closed to new replies.