WordPress.org

Support

Support » Miscellaneous » Akismet and IIS 6?

Akismet and IIS 6?

  • Running IIS6 (win2k3 server), PHP 5.0.5 and mysql 4.1.15.
    Been running wp1.5 for a while, just upgraded to wp2rc3 this evening. In general, everything seems to be working very well — kudos!

    My category links work now! Yay, one IIS related problem gone.

    One small issue. I thought this would be a good time to give Akismet a shot (been using SK2) but I can’t even get to the plugin page to enter my key.

    I activate the plugin and am prompted that I need to enter my key. I click the link and end up at:
    http://www.mysite.com/blog/wp-admin/plugins.php?page=c:\Inetpub\wwwroot\blog\wp-content\plugins\akismet\akismet.php
    which is essentially a blank page:
    Invalid plugin page

    Doesn’t that url look a little… odd… ?

    I’ve messed around with that url, but can’t seem to figure out what to manually make it to work.

    Ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • If you search for related keywords, you’ll find numerous posts ditto. Some of the posters have discovered that the key works fine in a day or so….

    So that goofy (malformed?) url will suddenly start working? I suppose I could turn it back on tomorrow and see what happens….

    (I did some searching but didn’t really hit anything in the beta group that appeared to be the same. Perhaps I missed ’em).

    As to the “goofy” url, I honestly couldn’t say – the other posters didn’t IIRC post urls. You would probably find the related threads in the 2.0beta forum. Let me look and see if I can find one of them….

    Okay, give a look at this thread. Couple of posters had luck waiting it out, piginzen far as I know has still not had any luck.

    http://wordpress.org/support/topic/51050

    Thank you! I’ll give it a read.

    [added after reading]

    Ah, I have a bit of a different issue. I never actually get to see a page where I might enter that key. I can see where waiting might work if the issue was my key. Alas, my issue is somehow related to the plugin or my site.

    Sounds like a similar issue to:
    http://wordpress.org/support/topic/50355

    See my reply (for possible solution) here:
    http://wordpress.org/support/topic/50355#post-276875

    Aye, similar yet different. Tried your “hack”, but no change. I still have yet to be able to get to any sort of Aksimet manage or configuration page. 🙁

    Seems like my url (refer to the long goofy url above) should be something like:
    http://www.mydomain.com/blog/wp-admin/plugins.php?page=akismet\akismet.php

    And that gets me closer. At least I see the “admin frame”, but still nothing to config.

    I’ve downloaded a fresh akismet plugin and installed it. same thing.
    All my other plugins are working just fine.

    I’m baffled.

    I am having the same problem – tried the posted “hack” as well as waiting it out for a while now, no success, it just doesen’t want to accept my key. I’ve tried to enter the key manually as well as cut&pasting. Could it be that I simply have a “wrong” key? I see that I’ve registered on wordpress.com, however, all support redirects me here, to the .org place.

    Does anyone know what is causing this? I am running wp 2.0.5, IIS 6.0 and fairly new versions of both PHP and MySQL.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Akismet and IIS 6?’ is closed to new replies.