Support » Plugin: Akismet » Akismet 2.5.0 server/connection problem

  • I just installed Akismet 2.5.0 this morning and ever since I’ve been getting the following errors:

    “kismet has detected a problem. A server or network problem prevented Akismet from checking 2 comments. They have been temporarily held for moderation and will be automatically re-checked in 20 mins.”


    “The key below was previously validated but a connection to can not be established at this time. Please check your server configuration.”

    What’s the problem here?

Viewing 15 replies - 1 through 15 (of 39 total)
  • Moderator James Huff


    Halfelf Minion 🚀

    Usually those things iron themselves out within the hour.

    Unfortunately, it’s hard to tell if the problem is on Akismet’s end or your server’s end, but I’m reasonably sure that the problem wasn’t on Akismet’s end (otherwise there’d be quite a few more folks with the problem).

    If you’re still having the problem, please contact Akismet support directly at

    Thanks – it hasn’t resolved itself, so I submitted a technical help request at Some more time Googling for similar issues has turned up others who have had the same issue, some of which resolved and others which did not.

    We’ll see what happens.

    I’ve had similar issues (…”A server or network problem prevented Akismet from checking 2 comments. They have been temporarily held for moderation and will be automatically re-checked in 20 mins….”) on and off since upgrading to 2.50.

    I have not had the problems re: key validation that the OP reports.

    I updated Akismet version this morning, and when I click on Akismet Stats it takes forever for the page to download. I see some of it, but the graphs aren’t showing, instead it lists the names of the graphs(hyperlinked). I have tried deactivating, and then activating it.

    Plugin Contributor Joseph Scott



    We’ve found that if a server can’t reach it is almost always due to a firewall, proxy server or network change at your hosting provider. Sometimes the problem comes and goes quickly, so 2.5 schedules periodic rechecks when it is unable to reach

    The graphs not showing up properly is a known issue at this point and we are working on an update to address that.

    As always, we are available to answer questions at

    I’ll see if my host’s firewall is the problem. Are there specific ports, IP addresses, or what have you that need to be opened in the firewall to permit Akismet to work right?

    Note that 2.4.n was working just fine through the firewall, but 2.5.0 may not be, so if changes were made to where/how Akismet is looking for spam info now, that would suggest that it’s those changes that need to be opened up in the firewall.

    I submitted my original problem (top of this thread) via the contact link this AM but have received no response yet.


    Same problem here. At first I thought it was an issue with Mod_Security and Googled it – what I found?

    to change the file located here:

    Ctrl+F: Find the line Below
    SecResponseBodyLimit 524288

    Replace it with:
    SecResponseBodyLimit 524288

    Did that and it still didn’t work.

    I think this can also be an issue with ConfigServer Firewall and it may just help everyone (including Akismet) if we also include our relevant known server setup that might correspond to this particular problem’s actual cause.

    Here goes mine:

    WordPress 3.03
    Akismet – 2.50
    Apache 2.2 (with low timeout)
    PHP 5.2.14
    Running Mod_Security
    Running ConfigServer Firewall with SynFlood Protection.
    Sysctl.conf includes Syn_Flood protection – On
    Custom HTaccess ruleset which shouldn’t be relevant I think.

    Plugin Contributor Joseph Scott



    I have good news about the graphs – they should now all be fixed.

    I got this “A server or network problem prevented Akismet from checking 1 comment…” message today, too. But it doesn’t seem to go away, i.e. after the displayed minutes, it just starts its countdown again. (While other spam comments still get successfully marked as spam, so it’s no permanent connection problem.)

    Some hours ago, I had received a standard “please moderate” mail for a typical spam comment with many links – so seemingly just one that Akismet didn’t catch – and clicked the link to mark it as spam. Only after that I noticed this problem message for the first time (having installed 2.5.0 the day it was released). Some time later, I deleted all the spam that had accumulated with the “empty spam” button, but the problem message persists. Is Akismet trying to re-check a comment that no longer exists? And if so, how to turn this message off? (Even if it means editing a database entry.)

    On another note, I noticed that my wp_commentmeta table is filling with hundreds of akismet_* entries, mostly akismet_history and akismet_result. That’s obviously related to the new features – but I hope those will be expired after a certain time and not flood the database with eventually tens of thousands of entries… will they?

    Plugin Contributor Joseph Scott



    Sounds like your server might be having issues reaching to check comments for spam.

    I’ve confirmed the issue with the comment_meta data and we are going to include a fix in the next release.

    Thanks for the reply. Well, Akismet successfully caught 44 spams over night but still displays this “…from checking 1 comment”.

    I investigated a bit more: There’s this one “akismet_error” db entry which contains the very same comment_id as the “please moderate” comment I mentioned yesterday, which I deleted – so Akismet is indeed trying to re-check a comment that doesn’t exist anymore: function akismet_check_db_comment, which is called from akismet_cron_recheck, returns an empty result since $wpdb->get_row returns nothing from the comment table, and thus akismet_cron_recheck in its “else” section just reschedules the recheck.

    Or in other words: akismet_check_db_comment (and thus akismet_cron_recheck) doesn’t distinguish between “comment doesn’t exist anymore” and “akismet_http_post, the communication with, had an error and returned ””…

    Plugin Contributor Joseph Scott



    I’m current w/ my upgrades and am still experiencing this problem…fwiw.

    Still experiencing this connection problem here too. I’ve only started seeing this issue with the upgrade to 2.5.1 from 2.4. I have not changed any server settings.

    I am also getting comment-moderation emails for clearly spam comments now.

    Plugin Contributor Joseph Scott



    Versions previous to 2.5 did not look for errors when connecting to, those errors were simply ignored.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Akismet 2.5.0 server/connection problem’ is closed to new replies.