WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Akismet 2.1.1 problem when deleting spam

[Resolved] Akismet 2.1.1 problem when deleting spam

  • Hi,

    This is what I get when I try to delete spam using the new Akismet plugin. When returning to the Akismet page I find that spam is actually deleted but I keep getting this error message when I first hit the “Delete all” button.

    The previous version worked okay.

    “Warning: Cannot modify header information – headers already sent by (output started at /home/longmead/public_html/just-thinkin/wp-content/plugins/akismet/akismet.php:283) in /home/longmead/public_html/just-thinkin/wp-includes/pluggable.php on line 391″

    I’m currently running WP 2.3.1 (PHP 4.4.7). My host (Bluehost) is due to switch all their servers to PHP 5.2.4 by the middle of January and my “box” should be converted soon. Just for info’s sake.

    I had to return to the previous version of Akismet and everything’s fine again.

    Anyone experiencing similar problems or perhaps has an idea of how to fix this?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Me too, and someother I know gets this error too.

    theapparatus

    @theapparatus

    Member

    There should be more to that error as usually you see it connected with additional errors. Please check your webserver’s error logs. Also check to see if either one of those files have any extra lines at the beginning of the file or after the closing ?> mark. There shouldn’t be any.

    I’m getting the same error after an upgrade to 2.1.1. For now, I think I am going to downgrade to 2.0.

    Okay, I checked and that’s all of the error I received and I verified it in the error log (the wp-admin error log that is…root directory error log was clear), no extra errors connected to it. Pluggable.php line 391 ending ?> looks okay…no extra lines after the ending ?> and the beginning of 391 appears okay also.

    The code for Aksimet is so vastly different from the previous version I wouldn’t know where to begin. I do appreciate your reply though unfortunately, it’s just as I said previously. The previous version works, the new one does not and it’s the only version of Akismet that I’ve ever had a problem with. I’m afraid I’m not versed enough in PHP to take it any farther myself.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    I see what’s causing the error. There a bunch of new style information added to the top of the akismet_caught function. The problem is that in some cases, that function will cause a redirect via new headers, and it can’t do that when output has occurred.

    So, that style info just needs to be moved into a better position, below the redirects.

    So, here’s my quick fix that I believe will correct the flaw:
    http://wordpress.pastebin.ca/820999

    Just for the record, 2.1.2 seems to fix this problem.

    I’m running Akismet 2.1.6 with WordPress 2.6.1 and getting the same or a similar error when trying to delete spam.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Akismet 2.1.1 problem when deleting spam’ is closed to new replies.