Support » Plugin: WP-Optimize » Ajax warning

  • Resolved kledij

    (@kledij)


    Hi,

    After updating to the new version, database is not optimizing anymore.
    I get : PHP errors were triggered during an Ajax request. See your browser developer console for details.

    After rolling back, its ok, so i think something is wrong with the update.

    Please can you help?

    Regards
    Bart

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same error here

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Apologies for the delay.

    Please could you open your browser’s developer tools (CTRL+SHIFT+J or F12 in most browsers), then open the developer console tab?
    Then, please repeat the optimisation attempt. Do you see errors appear in the developer console?
    If so, please could you send us a copy of those messages?

    {type: “warning”, message: “Creating default object from empty value”, file: “wp-content/plugins/wp-optimize/includes/class-wp-optimizer.php”, line: 318, stack: Array(7), …}
    component: “Plugin: wp-optimize”
    file: “wp-content/plugins/wp-optimize/includes/class-wp-optimizer.php”
    line: 318
    message: “Creating default object from empty value”
    stack: (7) [“WP_Optimizer->get_table()”, “WP_Optimization_optimizetables->optimize()”, “WP_Optimizer->do_optimization()”, “WP_Optimization->do_optimization()”, “WP_Optimize_Commands->do_optimization()”, “WP_Optimize->wp_optimize_ajax_handler()”, “do_action(‘wp_ajax_wp_optimize_ajax’)”]
    type: “warning”
    __proto__: Object

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Please could you try updating to the latest version (2.2.9)?
    Does this resolve the issue?

    No, this does not fix problem.
    I’m running php 7.2

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Apologies for the delay.

    Are you using any caching plugins on the site?
    If so, please could you try clearing all caches?

    I’m only using autoptimize.
    My site is on nginx + fastcgi cache.
    clearing cache does not work.

    Plugin Author David Anderson

    (@davidanderson)

    Can you confirm what you have on line 318 of the mentioned file? The error message you’ve pasted doesn’t seem to correspond to the current release.

    file: “wp-content/plugins/wp-optimize/includes/class-wp-optimizer.php”
    line: 318
    message: “Creating default object from empty value”
    stack: (7) [“WP_Optimizer->get_table()”, 

    Can I send you my login details, so you can check yourself?

    Plugin Author David Anderson

    (@davidanderson)

    The wordpress.org forum mods really dislike it if plugin owners say “yes” to that.

    Ok, I understand. I updated to latest version, i do not get error message anymore, but the database is still not optimizing.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    If you have not already, please could you set up logging for WP-Optimize, then run a database optimisation?

    Please could you then send us a copy of that log?

    kledij

    (@kledij)

    Hi,

    I just updated to WP-Optimize 2.2.11 , the problem is fixed now.
    Thanks!

    Plugin Author David Anderson

    (@davidanderson)

    Yes, we reproduced the issue and resolved it in 2.2.11. Thank you for confirming!

    David

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.