Support » Plugin: Stop Spammers » Ajax to StopForumSpam returns a message

Viewing 5 replies - 1 through 5 (of 5 total)
  • And the spammer does not show up in SFS at that.

    It could be one of many things.

    1) sometimes SFS is slow and I have a fairly short timeout on the reporting.

    2) PHP might not be configured to allow remote file access.

    3) The SFS API key might not be correct.

    if the error only happens on some spammers, then:

    4) The IP address might be the long version IPV6, which SFS does not handle, although I am told a fix is on the way, so I did not try to stop it.

    5) SFS has a limit on the size of the evidence. I cut the reporting link number short, but if there are a great many links with long URLS in the comment, it might be too long.

    Keith

    Wait, wait, assume nothing has changed, only the plugin was upgraded. It worked fine before.

    1) SFS is slow sometimes but usually it does not stay slow. So far I did not succeed submitting any requests.
    2) Remote file access? If you mean allow_url_fopen, then that’s disabled but it was always disabled. Did you change how you access SFS?
    3) Checked. Key is correct.
    4) IPV4
    5) Both long and short messages result in the same message.

    I tried resubmitting old spam that was in trash, the spam that was previously successfully submitted – same thing.

    The problem is the same on both network (multisite) and single standalone WP sites.

    I looked at the code and see that I use the “file_get_contents” function where I used to use the WP_HTTP class. I had some issues while debugging and, for me, the native PHP function worked better and faster.

    I will restore the old one. It defaults to using curl, I believe if the remote file access functions are disabled.

    I’ll make the change and let you know when I have it on BlogsEye.com for testing. If nobody objects I’ll release the new version the next day.

    Keith

    Excellent work. With 6.03 everything is back where it belongs and the spammers – at stopforumspam.com 🙂 Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Ajax to StopForumSpam returns a message’ is closed to new replies.