WordPress.org

Support

Support » Plugins and Hacks » [Resolved] AJAX scripts fail from whitespace after ?> in magic-fields-2-alt-get-audio.php

[Resolved] AJAX scripts fail from whitespace after ?> in magic-fields-2-alt-get-audio.php

  • Magenta Cuda
    Member

    @magenta-cuda

    The file “magic-fields-2-alt-get-audio.php” has extra linefeeds after the last ?>. This is causing AJAX scripts to fail. (AJAX scripts are typically used to provide new partial content to a page without reloading the whole page.) To correct this delete the extra linefeeds at the end of the file “magic-fields-2-alt-get-audio.php” or just disable the “Alt Audio” feature if you are not using it. (I always thought it was ugly to leave unbalanced PHP tags and I thought I would be careful enough to avoid this mistake but now having got burned I have learned my lesson – safety should have precedence over beauty.)

    Sorry for causing this trouble,
    mc

    http://wordpress.org/plugins/magic-fields-2-toolkit/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] AJAX scripts fail from whitespace after ?> in magic-fields-2-alt-get-audio.php’ is closed to new replies.