WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Ajax not working with the fix – Still not showing future months

[Resolved] Ajax not working with the fix – Still not showing future months

  • pluginsboy
    Member

    @pluginsboy

    Hello Ross,

    I have made a calender at this link:
    http://www.ledøjeforsamlingshus.dk/kig-i-kalenderen/

    ( xn--ledjeforsamlingshus-x7b.dk )

    And pagination does not work via Internet Explorer (9.0.8), when clicking next month, it keeps hanging on “Loading” (Tænker…) but in Mozilla Firefox this works perfectly as intended.

    Do you have any idea where the bug in your plugin or the site could be, that I could fix?

    I have also tried your plugin fix in another post, but still no luck. (I have not updated to 3.5 yet because I am worried I get even more unlucky with the plugin).

    Thanks in advance.

    Pluginboy

    http://wordpress.org/extend/plugins/google-calendar-events/

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Contributor Ross Hanney
    Member

    @rosshanney

    Hello,

    Apologies for not replying to your initial email, I’ve been quite busy the last week or so!

    This issue is really puzzling. I think it’s something to do with the way Internet Explorer handles the difference between the xn--ledjeforsamlingshus-x7b.dk and ledøjeforsamlingshus.dk versions of your domain name, but I’m not 100% sure about that.

    I’ll continue to investigate and let you know if I figure anything out.

    pluginsboy
    Member

    @pluginsboy

    Hi Ross,

    Thank you, because it is a real “pain” that no one can see in other months 🙂

    I will wait and cross fingers and hope that you will get a fix for this.

    I have not had any problems before with the domain name I must admit though.

    Happy New Year.

    Pluginboy

    Plugin Contributor Ross Hanney
    Member

    @rosshanney

    Hi again,

    I’ve created a little plugin that, when installed, should hopefully work around this problem. You can find the plugin code here.

    To install it, you’ll need to do the following:

    1. Copy / paste the code into Notepad (or any plain text editor)
    2. Save the file as gce-hardcode-ajax-url.php (set the encoding to UTF-8)
    3. Upload the file to your wp-content/plugins folder
    4. Activate the plugin in your WordPress admin

    Let me know if that does / doesn’t work, or if you have any further problems.

    pluginsboy
    Member

    @pluginsboy

    Hi Ross,

    Thanks!

    It seemed to do the trick. Thank you for the fix, it was exactly what I needed. A late Christmas gift 😉

    Best regards,
    Pluginsboy

    pluginsboy
    Member

    @pluginsboy

    Hello again Ross,

    I might have been too fast the other day.

    It works perfectly the fix you’ve made, but I can only move forward to May 2013 and then the “Next” button is gone, even though there is events long past May, and in admin I have from beginning of time to end of time setting, and refreshed the cache, and “Maximum number of events to retrieve” set to (500) way more than events there.

    Do you know the issue, and can divert me out of it?

    Thanks in advance.

    Socoliuc
    Participant

    @socoliuc

    Hi

    I also used the plugin you made,but still the same problem … next button dissapeared …

    Plugin Contributor Ross Hanney
    Member

    @rosshanney

    Pluginsboy,

    It looks like you have the max parameter of the [google-calendar-events] shortcode set to 10. I think the plugin is displaying more than 10 currently, as most of your events seem to be recurring events (the plugin only counts the first instance of a recurring events against the max value, which is sort of a bug).

    If you remove the max parameter, the plugin should display all the events it has retrieved.

    Plugin Contributor Ross Hanney
    Member

    @rosshanney

    Socoliuc,

    You may need to increase the “Maximum number of events to retrieve” option so that events further into the future are retrieved.

    pluginsboy
    Member

    @pluginsboy

    Thanks Ross, I believe it is a fault on my end, making some calender events private, I will test and see.

    pluginsboy
    Member

    @pluginsboy

    Hi Ross

    I am still having issues with this “Next” button. I will show you the front and admin section in images, so you can see what I mean.

    Image 1
    Image 2
    Image 3

    I hope you can help me figuring it out.

    I have used different browsers, cleared cache, clicked “Refresh feed”, waited a day to see if it worked afterwards – nothing helped.

    Plugin Contributor Ross Hanney
    Member

    @rosshanney

    Hello,

    It looks like you have the max parameter of the [google-calendar-events] shortcode on your page set to 10. If you remove the max parameter, it should display all events, allowing you to navigate further into the future.

    In the widget settings (Appearance > Widgets) it looks like you have the “Maximum no. events to display…” option set to 5. Try setting this to 0 (to display all events).

    I’ve got the same issue. We’re currently in Feb, I click on next month, it displays the events from March, but then the next button disappears and I can’t retrieve any more.

    What’s going on? By the way, this plugin is beautiful – if we can just crack this, it’d be even better!

    By the way, I’m not using shortcodes, I’m using it as a widget…

    Plugin Contributor Ross Hanney
    Member

    @rosshanney

    Hi Rapidz,

    What do you have the “Maximum number of events to retrieve” option set to? You may need to increase it so that events further into the future are retrieved.

    Wow, what incredible support, wasn’t expecting such a quick response.

    Ok, so when I go to the plugin settings, and then edit the feed, the maximum number of events to retrieve is set to 500.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] Ajax not working with the fix – Still not showing future months’ is closed to new replies.