Support » Fixing WordPress » AJAX not working in WP 2.3.1

  • I have successfully installed WP 2.3.1 in a variety of accounts on the same ISP using the same WP templates. However, in one install (which I have re-done twice now), all AJAX features fail to work correctly. Specifically, CFORMS II loads the plugin, but nothing “works” within posts. Also, the MYDASHBOARD plugin generates the following errors when I try to access the Dashboard page:

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 637

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 641

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 645

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 657

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 665

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 670

    Warning: array_push() [function.array-push]: First argument should be an array in /home/safespring/www/www/wp-content/plugins/mydashboard/mydashboard.php on line 675

    Anyone have any ideas on this one? The only thing I haven’t done is create a new database. I’ve spent a while populating this site and would prefer not to have to do this.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same issue, anyone have a solution to this?

    FYI – I just fixed it based on info from another forum, used the following steps:

    Can you try the following for me to see if that helps.
    1. De-activate the plugin.
    2. If you have access to phpmyadmin or some other database admin tool, connect to your WordPress database and look at the `wp_options table.
    3. Look for two entries, clearskys_dashboard_config and clearskys_dashboard_pages, and delete them.
    4. Re-activate the plugin and go to the Dashboard page.

    @ thisbejoe7

    This worked 😀 all working now 😀 thanks

    @thisbejoe7
    I can confirm too it works. But I find it very strange. My blog was working flawlessly, and suddenly (?) this problem appeared. Don’t knowing what to do to solve, I reinstalled the whole blog (in fact, I just used again the install script, after backing up ONLY the core WP databases) and the MyDashboard was working again.

    But a few days later, it just stopped working one more time, exactly what has been described in the first comment. So, OK, we have a solution, but how often will we have to apply it?

    Anyway, thanks to the author for this great plugin, my dashboard has space to breathe now 🙂

    Any plugin that messes with the dashboard will likely stop working in WordPress 2.5, as the dashboard has undergone radical surgery. Might keep that in mind before upgrading.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘AJAX not working in WP 2.3.1’ is closed to new replies.