Support » Plugin: WordPress Infinite Scroll - Ajax Load More » Ajax Load More Content Pages are Compressed and Jumbled

  • I’m using Elementor Pro and Elementor Hello Theme. I want to display pages rather than posts. I’m inserting shortcode at the end of any pages I want to have autoloading other pages.

    I have reset the repeater to show content. However when it opens the whole page the content is bunched up and overlapping rather than displaying as it should.

    The shortcode is:
    [ajax_load_more loading_style="infinite classic" post_type="page" posts_per_page="2" post__in="36322,36333,36312,36188,36344,36180,36319,36338,36327,36462,36195,36178,"]

    The repeater is:

    <li class="alm-item<?php if (!has_post_thumbnail()) { ?> no-img<?php } ?>">
       <?php the_content(); ?>

    Can you please let me know how to get the pages displaying with correct formatting?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author dcooney


    Hi @sqdcwp9999
    When I review your page the Ajax request is being block by a 403 (forbidden) error.
    “Failed to load resource: the server responded with a status of 403 ()”

    You likely have a plugin blocking access to wp-admin/admin-ajax.php

    I’m not sure if this is what you are seeing as a logged in user.

    Other than that, your repeater template does have an error. But I’m not exactly sure what you are trying to display so It’s hard to help.

       <?php the_content(); ?>
    Thread Starter sqdcwp9999


    Thanks for your reply. I’ll check with Sucuri about the 403 error. Do I need to change the ‘container type’ setting if I use the repeater you gave above? Are there any other settings to change in order to use that repeater?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Ajax Load More Content Pages are Compressed and Jumbled’ is closed to new replies.