Support » Plugin: Sliced Invoices - WordPress Invoice Plugin » Ajax links don’t work

  • Hello,

    I have problems with the links in quotes. nothing happens. Here’s my chat with sitrubix about the problem.

    ========
    In my admin left column, I have “Quotes” including the option to create a new quote. I tested it with success over the week-end. Now, when I try to create a new quote, the empty quote appears, but when I click the buttons, for example to create a new client, nothing happens.

    I think the problem is in WP, since when I look at all the quotes, I have the options to edit or quick edit. Edit brings me to the draft, but I STILL can’t create a new client and quick edit doesn’t respond.

    Could it have to do with AJAX? I noticed that the “add a new client” button links to http://merlinventaire.siterubix.com/wp-admin/post.php?post=319&action=edit#TB_inline?width=960&height=700&inlineId=add-ajax-user

    Thanks for your prompt response,
    Regis Thibeault,
    merlinregis

    SiteSupportabout 2 hours ago
    Hi Regis,

    In this case, we suggest you contact the plugin provider and ask them to provide you guidelines on this as that will certainly help.

    merlinregis24 minutes ago
    Hello again,

    Thanks for your prompt response.

    On https://wordpress.org/support/topic/add-new-client-wrapper-is-blank, for a similar they suggest that we might get an alert in the php log or in the browser control. I’ll check the browser console while you ceck the php log?

    merlinregis20 minutes ago
    In the console I get :

    decimal.min.js?ver=3.7.2:2 Uncaught Error: [DecimalError] Invalid argument: 14.975.00
    at b (decimal.min.js?ver=3.7.2:2)
    at new e (decimal.min.js?ver=3.7.2:2)
    at workOutTotals (admin.js?ver=3.7.2:158)
    at HTMLDocument. (admin.js?ver=3.7.2:357)
    at i (load-scripts.php?c=0&load;[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates,moxiejs,plupload&ver=4.9.6:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load;[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates,moxiejs,plupload&ver=4.9.6:2)
    at Function.ready (load-scripts.php?c=0&load;[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates,moxiejs,plupload&ver=4.9.6:2)
    at HTMLDocument.K (load-scripts.php?c=0&load;[]=jquery-core,jquery-migrate,utils,underscore,wp-util,wp-a11y,updates,moxiejs,plupload&ver=4.9.6:2)

    merlinregis19 minutes ago
    Does it have to do with my problem?

    SiteSupport16 minutes ago
    Regis,

    We just checked the server logs and we are seeing following error message:

    Premature end of script headers: admin-ajax.php, referer: http://merlinventaire.siterubix.com/wp-admin/post-new.php?post_type=sliced_quote

    Please contact plugin provider to know more about this.

    Premature end of script headers: admin-ajax.php, referer: http://merlinventaire.siterubix.com/wp-admin/post-new.php?post_type=sliced_quote
    ==========

    Thanks for your prompt response,

    merlinregis
    merlinventaire.com

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • UPDATE : While trying to figure out what was wrong, I noticed that I had the same problem elsewhere.

    Started deactivating my addons one by one to notice that the problem is on your side.

    When I wanted to select all of my extensions to deactivate them all at once, the select all button didn’t react.

    So one by one, I deactivated them, and when I deactivated sliced-invoices, the select all button came back to life.

    I “COULD” be interested in upgrading, but, obviously, if the extension is to cause problems regularly after updating or for no appearant reason, I don’t see why I’d upgrade.

    My site is already in production mode, but I can’t quote nor invoice using this. I wonder if I’ll find a replacement before getting an answer here :-S

    Thanks in advance to anyone who can help,

    merlinregis

    Plugin Support Andrea Whitmer

    (@nutsandboltsmedia)

    Apologies for the wait time – yesterday was a holiday in the US, and we don’t provide 24/7 support, unfortunately. I’ll ask our developer to take a look at this as soon as possible.

    Plugin Support Andrea Whitmer

    (@nutsandboltsmedia)

    Can you confirm what version of PHP is running on your server? Your host should be able to tell you if you don’t know for sure.

    Hello,

    Happy Monday! 😉

    Sorry for the delay.

    Current PHP version installed on the server is 5.6.33-1.

    Plugin Support Andrea Whitmer

    (@nutsandboltsmedia)

    Can you try disabling all plugins (other than Sliced) temporarily and see whether the Add New Client option works? If it does, please activate one plugin at a time, trying the option after each one, to see when the issue returns. This should help us identify which plugin is causing a conflict.

    already did that… the problem IS with sliced… when I activate sliced, the links don’t work anywhere… when I disable it, they come back to life.

    Smells like a corrupted installation. “IF” I uninstall it, will I STILL have my configurations? or will I lose them all and have to rebuild the whole thing from scratch?

    If I COULD lose my configs, can I back them up? Where do I find them?

    Thanks

    Plugin Support Andrea Whitmer

    (@nutsandboltsmedia)

    We would definitely be getting lots of tickets if this was a universal issue. You should be able to remove and replace the plugin with no loss of settings, but I’d recommend screenshotting each settings screen just in case.

    Let me know how that goes!

    I think I just might have found a potential cause of the problem : I didn’t notice that I had the Woo version AND the WP version… I just uninstalled the WP version, I’ll test to see if it still doesn’t work before uninstalling the woo version

    ok, I just got my answer when looking at the details of the woo version… it REQUIRES the WP version… so I’m uninstalling, then reinstalling both

    Nope 🙁

    Since the woo version of sliced invoices is included in the woo commerce options, I can only deactivate it. I think the problem is in there since I uninstalled the WP version, reinstalled it since it’s require by the woo version, but I still can’t work with it.

    Thanks for the follow up

    OK! So I FINALLY found how to uninstall it all… reinstalled it, but STILL doesn’t work

    Thanks for any other idea that could help

    Plugin Support Andrea Whitmer

    (@nutsandboltsmedia)

    Can you confirm this is happening even with no other plugins at all enabled? What about if you activate a default theme like Twenty Sixteen? I’ve tried to replicate the issue but Sliced by itself doesn’t throw any errors or cause any issues that I can find.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Ajax links don’t work’ is closed to new replies.