Support » Theme: Ascend » Ajax filters do not work on product archive page

  • First of all, thank you for this awesome theme! I’ve been using it for months and it’s been quite an experience.

    I tried to use a few different Ajax product filters, like FacetWP, in product archive page, but it does not work at all. The filter, actually, filter the results, but it returns a blank page (the results are there, but they are not displayed).

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello Samgomes,

    With the free theme, you’ll have to find a plugin that works. This is however, a built in function of the premium theme.

    Have you tried this plugin from YITH?
    https://wordpress.org/plugins/yith-woocommerce-ajax-navigation/

    It appears to be more widely used than facet, so it likely will function better with the theme.

    -Kevin

    Hey Kevin. Thank you for your reply.

    I tried this plugin, yes, but it happened to end with the same problem as FacetWP (the product is there, filtered. You can hover over it, but it simply does not show). There are also no errors in the console log. Can be an AJAX issue, since both plugins use it.

    I would love to use Ascend premium, but I’m in a budget right now (I only tested FacetWP because I happened to have a version around from an old project).

    It sounds like the theme has a fade-in animation that runs on pageload. First check to see if there’s a Customizer setting to disable the fade-in effect.

    If not, you’ll need to find where in the theme’s JS the effect is coming from. Then you’ll need to re-trigger the effect from within a “facetwp-loaded” JS event — to ensure that the fade-in fires for FacetWP’s ajax refreshes.

    I couldn’t find any setting like that. Does that makes sense to you, Kevin?

    Hey,
    You can disable aminate in by adding this css:

    .kt_item_fade_in {
        opacity: 1;
    }

    Ben
    Kadence Themes

    This worked out beautifully, Ben!

    Thank you so much for your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Ajax filters do not work on product archive page’ is closed to new replies.