Support » Plugin: Themify - WooCommerce Product Filter » Ajax Filter no Work on Safari

  • Resolved Emanuel Borbon

    (@eborbon)


    Hi

    The filter works perfect on chrome or Firefox, but on safari it disappears, looking on the console I got an error SyntaxError: Invalid regular expression: invalid group specifier name in public/js/wpf-public.min.js searching for solution I find that Safari doesn’t support lookbehind, so the problem could be in this part of code /(?<=paged=)[^\bs=]+/ the line of this code changes, but is around 12 or 13 line of the file

    Did you know this error on Safari or this will be fix soon?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author themifyme

    (@themifyme)

    Hi,

    Please post a link to your website, to the page where you have filter added, so we can check.

    Thread Starter Emanuel Borbon

    (@eborbon)

    This is one of the pages where we use the filter Site in the left sidebar

    Plugin Author themifyme

    (@themifyme)

    Hi,

    Sorry, but I can’t see the filter on the above shared URL: https://share.getcloudapp.com/nOuoRyKj have you removed the filter or the plugin? ( I checked with Chrome, Firefox and Safari on Mac )

    Thread Starter Emanuel Borbon

    (@eborbon)

    Hi

    Try Now, I made some changes in W3 Cache
    The filter was there, but for some reason have visibility: hidden
    Now in Edge and Firefox is working, but in safari still with visibility: hidden and no working. I try to change the CSS, but the problem is that no work the AJAX

    Plugin Author themifyme

    (@themifyme)

    Hi,

    I see the visibility set to hidden in Safari: https://share.getcloudapp.com/eDujX7Kn but it seems to be from your Divi Module or your Lazy Loading plugin, they block Ajax due to error, could you try using a Sidebar Widget area instead, if that works then the issue is the Divi Module, if the issue still persists, please try deactivating your third-party plugins, except WooCommerce, that should fix the issue.

    Thread Starter Emanuel Borbon

    (@eborbon)

    Hi

    I tried with the widget but still hidden, but I also tried to avoid minify a JS file of the plugin (public/js/wpf-public.js) by W3 Total Cache and now is working fine, so the minify option of the plugin was the problem

    Thanks

    Plugin Author themifyme

    (@themifyme)

    Hi,

    I’m glad it’s resolved. If you need help with anything else, please open a new topic, so we can help you there.

    Have a good day!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.