Support » Plugin: WebLibrarian » Ajax Error with Amazon

  • Resolved kmtrent


    Very excited to have just found this plugin! We are setting everything up. The AWS keys, region and Amazon associate tag have been inputted to the settings. But, when I try to search an item through the search box at the bottom of add item page…I get this message:
    AJAX error: 0

    Any ideas on how we could resolve this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Just typed in info for a new item and when I hit the ADD ITEM button, this is the error received:

    You don’t have permission to access /wp-admin/admin.php on this server.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Here’s a copy of my PHP error log:
    PHP Warning: Invalid argument supplied for foreach() in l/wp-content/plugins/weblibrarian/includes/WEBLIB_Statistics_Admin.php on line 145
    [06-Apr-2014 21:45:32 UTC] PHP Warning: Invalid argument supplied for foreach() in /wp-content/plugins/weblibrarian/includes/WEBLIB_Statistics_Admin.php on line 145

    Turned on the Debug database setting and made database. This helped the ADD ITEM issue, but I am still getting the same error for search option.

    well…it let me add one item…now I’m back to same error…

    Here’s a new php error:
    [06-Apr-2014 23:31:08 UTC] PHP Fatal error: Call to a member function show_errors() on a non-object in /wp-content/plugins/weblibrarian/includes/database_code.php on line 865

    Sorry for all the posts. Thinking maybe my process will help identify a way to help.

    Plugin Author Robert Heller


    Several things:

    First, have you entered the correct Amazon credentials? You need the public and private keys, plus an associate’s id.

    Additionally, I have some questions:

    1) What O/S does your web hosting server run (Linux or MS-Windows)?
    2) Is your WordPress install a single site install or a multi-site/networked install?
    3) Which web browser are you using (Firefox, Chrome, Safari, or IE)? Under what operating system (MS-Windows, Linux, MacOSX, Android, or Ios)?

    There have been problems reported with MS-Windows as the web site hosting server. *I* don’t have any way of supporting this plugin with WordPress running on a MS-Windows server. There have also been problems with this plugin with WordPress running as a multi-site or networked installation (I don’t know what the problem there is, but I suspect it is some weirdness with users and roles in that environment or something).

    Yes, I have acquired and inputted all the Amazon information.

    1. My hosting lists the platfom type as Debian. Is this what you need?
    2. Single
    3. Chrome, MS-Windows

    I am still experiencing all the issues, but occasionally the add item button will work. I have to leave out all apostrophes and hold my head just right (haha).

    Plugin Author Robert Heller


    Where are there apostrophes in your input (which input fields). This sounds like a quoting bug somewhere in the input sanitizing code.

    I have found that the issues with adding items was how my site dealt with the punctuation inside the titles or descriptions. Since these are rendered as urls, the apostrophes, backslashes, and even periods present a problem. My security walls also see these markings as hacking attempts.

    But, I am adding items now though! Still getting the AJAX error: 0 with the Amazon search, and I am simply not using this option.

    Plugin Author Robert Heller


    The only thing I can think of is that there is some weird with your hosting service. Question: is your wordpress install part of a network or multi-site install? This could be causing problems somehow.

    My only other idea would be to use firefox w/firebug installed and look at the Amazon AJAX calls in the firebug console — that might be imformative.

    Thank you! You have been great to get right back to me about my concerns. I will keep troubleshooting and let you know if I discover the issue. We are not multisite, but we do use lots of plugins and hefty security.

    I do have to keep all the input fields clear of apostrophes when adding an item. Also, a dash has presented an issue in the title field.

    Plugin Author Robert Heller


    See the other ‘resolved’ Ajax/Amazon error thread. It appears the Debian-flavored linux distros don’t include the curl module for php as part of the base php install. It is a separate package that needs to be installed.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Ajax Error with Amazon’ is closed to new replies.