CommentPress Core
[resolved] [closed] AJAX Error when attempting to submit a comment (5 posts)

  1. sico7
    Posted 2 years ago #


    I have the CommentPress Core plugin installed in a WordPress multisite installation and receive an AJAX error whenever I try to submit a comment.

    The error that appears says:

    AJAX error!
    TypeError: a is undefined

    I found a support thread over in a Google group relating to Digress.it that mentioned a problem with CommentPress in a https environment and also mentioned subdirectories. That thread can be viewed here (last comment):


    The URL of the site where I'm having the problem is:


    I'm really keen to make use of this plugin as it is exactly what we need for collaborative authoring of texts.

    Any help you can provide would be much appreciated.




  2. Christian Wach
    Plugin Author

    Posted 2 years ago #

    Hi Simon,

    Thanks for the report. I presume you are seeing the ajax error when you're logged in - I can't verify the error as commenting on your site requires a login. If you add me as a user using the email address on this plugin's description page, I'll see if I can find out why.

    In the meantime:

    • Do you have any other plugins active?
    • Which browser are you using?
    • Have you tried commenting with a fully cleared cache?

    BTW, the commenting error under https was fixed a long time ago and shouldn't be the issue, nor should it be to do with a multisite installation.

    Cheers, Christian

  3. sico7
    Posted 2 years ago #

    Hi Christian,

    Thanks for getting back to me.

    I've added you to the site with the role of Subscriber (please let me know if you need me to change the role) using the cpdev email from the plugin description page. You should receive a confirmation email.

    As this site is a very early work in progress the CommentPress plugin is the only one that is currently active.

    I have tried submitting comments using Firefox (v26.0), Safari (v6.0.5) and Chrome (v33.0.1750.117) all on Mac OSX and all with clear browser caches.

    If you need any further information please don't hesitate to contact me.



  4. MrJKConnor
    Posted 2 years ago #

    I have encountered this problem.

    The message I get is slightly different but also happens when submitting a comment.

    AJAX error!

    TypeError: Cannot read property 'toString' of undefined

    The site I am testing on does not require a log in to repeat the issue.


    and try and comment on a paragraph.

    Any help here would be useful.

    More info. The error comes up, then the comment appears to be posted not on the paragraph but on the page as a whole when you refresh the page.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    This resovled topic is now more than 2 months old, so I am closing it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • CommentPress Core
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.