• Hi!

    I’m getting an ajax error when I try to send a testmail. I have done this setup on more then 20 websites and works everytime. Trying to connect with Mailgun API.

    This is the error in the log:
    [Tue Oct 26 18:15:23.592441 2021] [proxy_fcgi:error] [pid 19831:tid 140002536924928] [client 85.146.210.226:46116] AH01071: Got error 'PHP message: PHP Fatal error: Cannot redeclare Clue\\StreamFilter\\append() (previously declared in /home/505391.c..............n /home/505391.cloudwaysapps.com/rvwtcxfner/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/mailgun/vendor/clue/stream-filter/src/functions.php on line 27', referer: https://business-leads.nl/wp-admin/admin.php?page=postman%2Femail_test

    Diagnostic test:

    Mailer: postsmtp
    HostName: business-leads.nl
    cURL Version: 7.52.1
    OpenSSL Version: OpenSSL/1.0.2u
    OS: Linux 505391.cloudwaysapps.com 4.9.0-14-amd64 #1 SMP Debian 4.9.246-2 (2020-12-17) x86_64
    PHP: Linux 7.3.31-1+0~20210923.88+debian9~1.gbpac4058 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=No, zlib_encode=Yes
    WordPress: 5.8.1 nl_NL UTF-8
    WordPress Theme: Business Leads
    WordPress Plugins: Adminimize, Amelia, Elementor Pro, Elementor, JetEngine, JetSmartFilters, Make Column Clickable Elementor, Post SMTP, Quform, Rank Math SEO, ShortPixel Image Optimizer, SVG Support, User Switching, WP Rocket, WPS Hide Login
    WordPress wp_mail Owner: /home/505391.cloudwaysapps.com/rvwtcxfner/public_html/wp-content/plugins/post-smtp/Postman/PostmanWpMailBinder.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, PostsmtpMailer->get_mail_args
    Postman: 2.0.23
    Postman Sender Domain (Envelope|Message): business-leads.nl | business-leads.nl
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: Mailgun API (https://api.eu.mailgun.net:443)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 5 | 0

    Already deactivated plugin and activated again. Any idea how to fix this?

    • This topic was modified 9 months, 2 weeks ago by busybees.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter busybees

    (@mick69145)

    As an addition: when I set the SMTP type to default I get no error. Only with Mailgun API type activated. When mentioned before, I use Mailgun API for more then 20 wehsites, on the same server, with no problem.

    getting same error, look like wordpress update broke the plugin.

    Following. Works using Mailgun API on non-woocommerce site, but not with woocommerce site.

    Thread Starter busybees

    (@mick69145)

    @quintont @nishantk I’m using the plugin on a wordpress site 5.8.1 running woocommerce. There it works fine. For the site where I run in the ajax problem, I use WP Amelia. This plugin has a function to setup SMTP. I guess this conflicts with Post SMTP so I’ve setup the SMTP with WP Amelia. I’m in contact with Amelia support to check if this is the case.

    Maybe you have a plugin that conflicts with Post SMTP. Have you tried deactivating all the plugins?

    Hi @mick69145 @quintont @nishantk

    Sorry that I am only just getting around to reading your forum post and replying to you. I have been super busy lately, and this is the first opportunity I’ve had to respond.

    Please could you confirm if there is still an issue to be looked at here?

    Thanks!

    Kind Regards,
    Tim

    Thread Starter busybees

    (@mick69145)

    Just tried the Post SMTP again and still get the Ajax error.

    In the meantime I use WP Mail SMTP. This works fine.

    Hi @mick69145,

    Please could you paste a copy of your Post SMTP diagnostics log? Thanks.

    Kind Regards,
    Tim

    yes, I’m still getting the ajax error when doing a test email in Post SMTP.

    <p>There has been a critical error on this website.</p><p>Learn more about troubleshooting WordPress.</p>

    Mailer: postsmtp
    HostName: univetpharm.com
    cURL Version: 7.52.1
    OpenSSL Version: OpenSSL/1.0.2u
    OS: Linux 558897.cloudwaysapps.com 4.9.0-14-amd64 #1 SMP Debian 4.9.246-2 (2020-12-17) x86_64
    PHP: Linux 7.4.27 en_US.UTF-8
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=No, zlib_encode=Yes
    WordPress: 5.8.3 en_US UTF-8
    WordPress Theme: Electric Villages
    WordPress Plugins: Advanced Custom Fields, All-in-One WP Migration Unlimited Extension, All-in-One WP Migration, Product Feed Manager for WooCommerce, Breeze, Broken Link Checker, Constant Contact Forms for WordPress, Constant Contact + WooCommerce, Honeypot for Contact Form 7, Contact Form 7, Docket WP, Yoast Duplicate Post, Facebook for WooCommerce, Flamingo, GenerateBlocks Pro, GenerateBlocks, GP Premium, MalCare Security - Free Malware Scanner, Protection & Security for WordPress, Post SMTP, Safe SVG, Smart WooCommerce Search, WooCommerce Invoice Gateway, WooCommerce Offline Credit Card Processing, WooCommerce, Wordfence Security, SEOPress, WP Show Posts Pro, WP Show Posts, WP Unit Converter
    WordPress wp_mail Owner: /home/558897.cloudwaysapps.com/nbchuszffj/public_html/wp-content/plugins/post-smtp/Postman/PostmanWpMailBinder.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, PostsmtpMailer->get_mail_args
    WordPress wp_mail_from Filter(s): wordfence::fixWPMailFromAddress
    WordPress phpmailer_init Action(s): wpcf7_phpmailer_init
    Postman: 2.0.23
    Postman Sender Domain (Envelope|Message): univetpharm.com | univetpharm.com
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: Mailgun API (https://api.mailgun.net:443)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 662 | 1
    Thread Starter busybees

    (@mick69145)

    I’m getting the same error as @quintont gets. I also host websites on Cloudways. Maybe this has something to do with the error?

    • This reply was modified 6 months, 3 weeks ago by busybees.

    @busybees – I will submit a ticket with Cloudways. Thanks.

    Cloudways won’t help me. Their solution is to use a different plugin!

    @tneville and @mick69145

    Cloudways has one final comment:

    PHP Fatal error: Cannot redeclare Clue\\StreamFilter\\append() (previously declared in /home/505391.c…………..n /home/505391.cloudwaysapps.com/rvwtcxfner/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/mailgun/vendor/clue/stream-filter/src/functions.php on line 27′, referer: https://business-leads.nl/wp-admin/admin.php?page=postman%2Femail_test
    
    
    these errors are related to the plugin,we don’t create blockage for plugins.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Ajax error’ is closed to new replies.