Support » Plugin: WebLibrarian » Ajax Error?

  • Resolved toomeya

    (@toomeya)


    I’m attempting to connect patron IDs with the enrolled WordPress users and I get an error that says:
    Ajax error: No Data Received

    How do I fix this? The only ID I have managed to change is the patron ID for the librarian account itself. I also can’t remove the IDs either.

    I’m on the screen that says “Add Patron Ids to Users” within the main WordPress login, but I also tried it within the librarian account with the same results.

    Any help would be great. Thanks,
    Amanda Toomey

    http://wordpress.org/plugins/weblibrarian/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Robert Heller

    (@robertpheller)

    What web browser are you using? What version? What desktop O/S?

    What operating system is your server running? What Version? What is your server running for a web server? What Version? What version of PHP? What version of MySQL? What version of WordPress? What version of the Web Librarian?

    I cannot replicate this error with my test site.

    I am using Windows 7 with Chrome version 30.0.1599.101m.
    I don’t have all the server details, because the server is maintained by another IS department, but I believe it’s a Linux/Unix based server.
    We are running WordPress 3.6.1 and Web Librarian 3.2.9.9

    I just tried in Firefox and IE and it doesn’t work in either of those browsers either.

    Plugin Author Robert Heller

    (@robertpheller)

    OK, please try to find out what O/S the server is running, etc. This error *suggests* that the server is a Windows Server, possibly running IIS. That is a *bad* combination. Windows Server and IIS are strange beasts and have various issues.

    I contacted IS and we are running a Linux server. I am attempting to get the exact version.

    I’m also getting the same Ajax error when I try to put a hold on an item.

    Plugin Author Robert Heller

    (@robertpheller)

    Please try this:

    In the location field of a web browser (not in any search field!) enter this URL:

    http://<your WP hostname>/wp-content/plugins/weblibrarian/UpdatePatronID.php

    (Replace <your WP hostname> with your actual WordPress host name.)

    And let me know what you get. You *should* get an XML response (it might ask you to login to your WP site) that looks like:

    <?xml version="1.0" ?><answer><userid></userid><patronid></patronid></answer>

    If you get something else (or any sort of error message), let me know.

    I got the login page to come up, but when I log in it says:

    “Fatal error: Call to undefined function wpcf7_add_tag_generator() in /var/www/education/wp-content/plugins/hashcash-for-contact-form-7/wpcf7_wphc.php on line 138”

    Ok, I shut off the plugin that was causing that error, but now when I click on the “Update ID” button it doesn’t do anything at all.

    Ok, I refreshed the page and now they’ve updated. Is there a way to have it give me some sort of visual signal that the data has been updated?

    Thanks for the help!

    Plugin Author Robert Heller

    (@robertpheller)

    It is supposed to update — that is how AJAX works :-). Can you try to run the UpdatePatronID.php URL with the conflicting plugin turned off? Something else seems to be broken. The conflicting plugin issue seems weird — there might be something else broken somewhere.

    I’ve got the conflicting plugin turned off and that’s what allows me to use the update button, but nothing happens on the screen until I refresh the page. We can work with it this way, I’m just not sure why I’m not seeing the updates as soon as I hit the button.

    Plugin Author Robert Heller

    (@robertpheller)

    Something is causing the php code to either crash or not send the proper XML. Please run the php code outside of the AJAX (JavaScript). This should provide some sort of error message or something, which should explain what is happening.

    As a random guess, there might be another plugin causing trouble or something weird in your server’s settings or something (like a bad version of PHP, MySql, Apache, etc.).

    I don’t know how to run the code outside of the AJAX within wordpress.

    Plugin Author Robert Heller

    (@robertpheller)

    Just run the

    http://<your WP hostname>/wp-content/plugins/weblibrarian/UpdatePatronID.php

    URL in the location bar of your web browser — the same way you got the error about the conflicting plugin. I expect there to be another (different) error message, which will help narrow down the problem.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Ajax Error?’ is closed to new replies.