WordPress.org

Support

Support » Plugins and Hacks » WordPress Flickr Embed » [Resolved] AJAX error

[Resolved] AJAX error

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’m experiencing the same error. Although this is my first time installing so it’s never worked.

    Looks like it might be related to my https everywhere plugin I have installed. Or perhaps another one. I tried opening it in an incognito window and I didn’t get an error.

    When I opened the page normally (when I get the error) I used the javascript console to catch this debug info (replaced my website url with <mywebsite>):
    Blocked a frame with origin “http://<mywebsite>.com” from accessing a frame with origin “https://widgets.wp.com”. The frame requesting access has a protocol of “http”, the frame being accessed has a protocol of “https”. Protocols must match.
    onloadwff.js:463
    Blocked a frame with origin “https://widgets.wp.com” from accessing a frame with origin “https://public-api.wordpress.com”. Protocols, domains, and ports must match. onloadwff.js:463

    So it looks like the use of the iframes violates some best practices guidelines that whatever plugin I have enforces for additional security.

    I’m getting this error: AJAX error: error (Forbidden)

    WP 3.5.2

    Is the developer still monitoring this forum and/or making updates to the plugin?

    Plugin Author hiddentao

    @randomaniac

    @tommasz Sorry about the delay in reply. I haven’t yet tried with WP 3.5.2 so let me try that and let you know if I have the same problem.

    Plugin Author hiddentao

    @randomaniac

    Just tried with 3.5.2 and it works great for me.

    * What version of PHP are you running?
    * Are you on a shared WP hosting service, i.e. is your site in a subfolder of the root domain?
    * Are you running a multi-language site?

    Here is my PHP info:

    PHP Version: 5.2.17
    PHP Memory Usage: 54.41 MB
    WordPress Admin Memory Limit: 256M
    WordPress Base Memory Limit: 128M
    PHP Actual Configuration Memory Limit: 90M
    PHP Max Upload Size: 7M
    PHP Max Post Size: 8M
    PHP Safe Mode: Off
    PHP Allow URL fopen: On
    PHP Allow URL Include: Off
    PHP Display Errors: On
    PHP Display Startup Errors: Off
    PHP Expose PHP: Off
    PHP Register Globals: Off
    PHP MySQL Allow Persistent Connections: On
    PHP Output Buffering: 4096
    PHP Max Script Execution Time: 240 Seconds
    PHP Magic Quotes GPC: Off
    PHP open_basedir: not in use
    PHP XML Support: Yes
    PHP IPTC Support: Yes
    PHP Exif Support: Yes

    I am on Dreamhost, but my site is on the root of http://www.tommasz.net/

    Single language. It should be noted that this plugin was working fine before. Not sure when it stopped since I hadn’t posted anything from Flickr in a while.

    i have the same problem 🙁

    Plugin Author hiddentao

    @randomaniac

    Could you try clearing your browser cache for me please? If you’re using Chrome you can goto Settings -> Advanced -> Clear Browser data.

    Also, if using Chrome, could you turn on the developer tools (Tools -> Developer Tools) and retry inserting a Flickr image. Any Javascript error will then show up in the Console.

    All of this will help towards figuring out what’s wrong.

    The error exists after cached is clear and on multiple browsers (Firefox and Chrome).

    I’m on Firefox. I cleared the cache, no change. Here’s the Web Developer console output:

    [08:56:47.386] Use of attributes' specified attribute is deprecated. It always returns true. @ http://www.tommasz.net/wp-admin/load-scripts.php?c=1&load%5B%5D=jquery,utils,plupload,plupload-html5,plupload-flash,plupload-silverlight,plupload-html4,plupload-handlers,json2&ver=3.5.2:2
    [08:56:47.486] POST http://www.tommasz.net/wp-admin/admin-ajax.php [HTTP/1.1 200 OK 4012ms]
    [08:56:47.487] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/alignment_left.png [HTTP/1.1 200 OK 16ms]
    [08:56:47.487] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/alignment_center.png [HTTP/1.1 200 OK 21ms]
    [08:56:47.488] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/alignment_right.png [HTTP/1.1 200 OK 22ms]
    [08:56:47.489] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/size_square.png [HTTP/1.1 200 OK 20ms]
    [08:56:47.489] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/size_small.png [HTTP/1.1 200 OK 16ms]
    [08:56:47.490] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/size_medium.png [HTTP/1.1 200 OK 19ms]
    [08:56:47.490] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/size_large.png [HTTP/1.1 200 OK 16ms]
    [08:56:47.491] GET http://www.tommasz.net/wp-content/plugins/wp-flickr-embed//images/size_original.png [HTTP/1.1 200 OK 24ms]
    [08:56:47.492] GET http://www.tommasz.net/?__wpfe_sign=%7B%22text%22%3A%22%22%2C%22page%22%3A1%2C%22user_id%22%3A%2241894175858%40N01%22%2C%22photoset_id%22%3Anull%2C%22per_page%22%3A18%2C%22sort%22%3A%22date-posted-desc%22%2C%22extras%22%3A%22url_sq%2Curl_m%22%2C%22method%22%3A%22flickr.photos.search%22%2C%22format%22%3A%22json%22%2C%22nojsoncallback%22%3A1%7D [HTTP/1.1 403 Forbidden 2259ms]

    Hi !

    I have an ajax error too, even if it’s not the same.
    I’ve clean my Chrome settings and it’s still there.

    AJAX error: parsererror (SyntaxError: Unexpected token <)

    Plugin Author hiddentao

    @randomaniac

    Thanks @tommasz, the error is this line:

    GET http://www.tommasz.net/?__wpfe_sign=%7B%22text%22%3A%22%22%2C%22page%22%3A1%2C%22user_id%22%3A%2241894175858%40N01%22%2C%22photoset_id%22%3Anull%2C%22per_page%22%3A18%2C%22sort%22%3A%22date-posted-desc%22%2C%22extras%22%3A%22url_sq%2Curl_m%22%2C%22method%22%3A%22flickr.photos.search%22%2C%22format%22%3A%22json%22%2C%22nojsoncallback%22%3A1%7D [HTTP/1.1 403 Forbidden 2259ms]

    Your WP hosting configuration is not allowing the plugin to use custom query variables (http://codex.wordpress.org/WordPress_Query_Vars). Are you running Apache? I suspect you will need to update your rewrite rules or something similar.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] AJAX error’ is closed to new replies.
Skip to toolbar