Support » Plugin: Web Stories » Again, for the third time, my editor is not working

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    Sorry to hear you’re having issues with the editor again!

    We don’t have access to users’ sites and cannot “force updates” or anything—but we’re eager to help you as good as possible.

    Was there anything that changed since last time? What’s the error message now?

    Thread Starter knowstuff

    (@knowstuff)

    I think I know where the problem is, but I have no idea how to fix it:

    Everytime I use hummingbird (WordPress plugin) asset optimization (which is a tool that compresses and optimizes assets of the site), this error occurs.

    I tried uninstalling hummingbird and deleting all its configurations, but It didn’t work.

    And yes, the error is the same from last time (and the same message in console):

    • Uncaught SyntaxError: missing ) after argument list: edit-story.js:4
    • Unchecked runtime.lastError: The message port closed before a response was received: post-new.php?post_type=web-story:1
    • Failed to load resource: net::ERR_BLOCKED_BY_CLIENT: api.js:1
    • Uncaught Error: Minified React error #200; visit https://reactjs.org/docs/error-decoder.html?invariant=200 for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
      at I.render (react-dom.min.js?ver=16.13.1:13)
      at schema-classic.js?ver=1.0.56.1:1
    • Failed to load resource: net::ERR_BLOCKED_BY_CLIENT: api.js:1
    • Unchecked runtime.lastError: The message port closed before a response was receive: finish:1
    • This reply was modified 10 months, 1 week ago by knowstuff.
    Thread Starter knowstuff

    (@knowstuff)

    @swissspidy

    Can you help me here?

    Plugin Support Luckyna San

    (@luckynasan)

    @knowstuff Hi there, thanks for your report.

    It appears there are incompatibilities with that optimization plugin and Web Stories when the CSS files and JavaScript files options on the Assets Optimization tab are enabled.

    Web Story post is an AMP document, and AMP is a framework built with its own optimizations. AMP documents must follow certain specifications in the code.

    You can exclude the “web-stories” URL in the settings to prevent optimization on those posts under Caching > Exclusions and enter in the directory exclusion /web-stories/(.*).

    Could you please let us know if there are any issues?

    Thanks!

    Thread Starter knowstuff

    (@knowstuff)

    It didint work…

    • This reply was modified 10 months ago by knowstuff.
    Plugin Support Luckyna San

    (@luckynasan)

    @knowstuff Could you confirm if you’ve cleared the cache, and tried in an incognito window?

    Thread Starter knowstuff

    (@knowstuff)

    @luckynasan

    Yes!! I cleared the cache and opened in an incognito window, but it didn’t work.

    Plugin Author Pascal Birchler

    (@swissspidy)

    I am a bit confused about why Hummingbird would affect the editor, as it seems to be a plugin for frontend optimization. Especially since you say that uninstalling doesn’t do anything.

    Also, some of the console error messages are not related the Web Stories plugin at all. For example “Uncaught Error: Minified React error […] at schema-classic.js” is probably coming from RankMath SEO.

    The “Uncaught SyntaxError: missing ) after argument list” error seems most relevant here, yet a bit ambigious.

    For this reason, could you please install the 1.3.0 development version (Link: https://github.com/google/web-stories-wp/releases/download/v1.3.0/web-stories-dev.zip)? This should give some more readable error messages.

    Also try temporarily disabling all other plugins before checking the console errors (so we don’t get any unrelated errors there)

    Thread Starter knowstuff

    (@knowstuff)

    @swissspidy

    I don’t know why, but with this 1.3.0 development version It worked just fine.

    Thanks man!

    Plugin Author Pascal Birchler

    (@swissspidy)

    That’s good to know!

    Shortly after I posted my message, I was able to reproduce this issue with a test site on your hosting provider. Some security feature there (SiteLock?) seems to forcefully modify our plugin’s JavaScript files when being accessed so that it causes this error.

    Luckily, I found a possible workaround that we’ll try to implement for our next release, but you might want to talk to your hosting provider as well.

    Thread Starter knowstuff

    (@knowstuff)

    @swissspidy

    Thanks! Already sent them a message to see more about this error!

    Thread Starter knowstuff

    (@knowstuff)

    @swissspidy

    Hey!! I am having the same mistake again, can you help me, please?

    Plugin Author Pascal Birchler

    (@swissspidy)

    Hi there,

    Is the error message the same this time or slightly different? Have you heard back from your hosting provider? Unfortunately there’s only so much we can do on our side to try to work around this conflict. Ideally the hosting provider would fix this on their end.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Again, for the third time, my editor is not working’ is closed to new replies.