WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] After WP 2.3.2 upgrade, <?php require(‘post.php’); ?> tag no longer works

[Resolved] After WP 2.3.2 upgrade, <?php require(‘post.php’); ?> tag no longer works

  • My code for inserting post to front page have always worked until I upgraded to 2.3.2 today and now my website isn’t displaying full code after the php require tag for post area:

    Original code:

    <div id="post">
    	<?php if ($posts) : foreach ($posts as $post) : start_wp(); ?>
    	<div class="post">
    		<?php require('post.php'); ?>
    		<?php comments_template(); // Get wp-comments.php template ?>
    	</div>
    	<?php endforeach; else: ?>
    	<p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    	<?php endif; ?>
    	<p align="center"><?php posts_nav_link() ?></p>
    </div>

    The code for post.php is:

    <p class="post-date"><?php c2c_the_category_image(' '); ?></p>
    <div class="post-info"><h2 class="post-title"><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>
    <?php the_category(', '); ?> | <?php the_time('M j, Y'); ?> | <img src="http://www.artofadambetts.com/weblog/wp-content/themes/aoab2/img/comment-mini.png" align="bottom" /><?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?>&nbsp;</div>
    <div class="post-content">
    	<?php the_content(); ?>
    	<div class="post-info">
    		<?php wp_link_pages(); ?>
    	</div>
    	<div class="post-footer">&nbsp;</div>
    </div>

    Currently I’m using a code snippet from default theme for http://www.artofadambetts.com/ but I’d like to find what’s wrong with this code. Thanks.

Viewing 1 replies (of 1 total)
  • what did you (or if anyone else might know) end up doing to fix this if you dont mind me asking? thanks!

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] After WP 2.3.2 upgrade, <?php require(‘post.php’); ?> tag no longer works’ is closed to new replies.
Skip to toolbar