WordPress.org

Support

Support » Plugins and Hacks » After W3 Total Cache plugin update actions generates 500 Internal Server error

After W3 Total Cache plugin update actions generates 500 Internal Server error

  • Unfortunately, after update version (9.2.4) the actions no longer easy where (Save new post) and (Empty All Caches) become an impossible operations.
    The issue is the (New Post) SAVED but whether (500 Internal Server Error) appears or ->

    • Warning: stripos() [function.stripos]: needle is not a string or an integer in /../wp-includes/functions.php on line 658
    • Warning: stripos() [function.stripos]: needle is not a string or an integer in /../wp-includes/functions.php on line 661
    • Warning: Cannot modify header information – headers already sent by (output started at /../wp-includes/functions.php:658) in /../wp-includes/pluggable.php on line 876

    I tried continuously to resolve this issue but i failed the ONLY way to resolve it is by disable (Page & Database Cache) but the Plugin will no longer valuable.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Enable the WordPress debugging system in wp-config.php and you’ll discover two directories need their permissions changing via FTP; Change those and it will work. I also found that I lost my W3 Total Cache configuration after the last update.

    Mind sharing what those two directories are?

    chmod 777 wp-content/cache/tmp
    chmod 777 wp-content/w3tc-config

    Should do it.

    I’m getting a wacky error message that is telling me in part to update those two files, but I can’t find the first one in cPanel. Help! This is the error message in full:

    “Fatal error: Uncaught exception ‘FileOperationException’ with message ‘/home/corporet/public_html/wp-content/w3tc-config/master.php could not be created, please run following command:

    • <strong style=”color: #f00;”>chmod 777 /home/corporet/public_html/wp-content/cache/tmp
    • <strong style=”color: #f00;”>chmod 777 /home/corporet/public_html/wp-content/w3tc-config
    • ‘ in /home/corporet/public_html/wp-content/plugins/w3-total-cache/inc/functions/activation.php:127 Stack trace: #0 /home/corporet/public_html/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error(‘/home/corporet/…’, Array) #1 /home/corporet/public_html/wp-content/plugins/w3-total-cache/lib/W3/Config.php(71): W3_ConfigWriter->save() #2 /home/corporet/public_html/wp-content/plugins/w3-total-cache/lib/W3/CloudFlare.php(174): W3_Config->save() #3 /home/corporet/public_html/wp-content/plugins/w3-total-cache/lib/W3/Plugin/CloudFlare.php(52): W3_CloudFlare->update_ip_ranges() #4 /h in /home/corporet/public_html/wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 127″

    I had to login via FTP and MANUALLY create wp-content/cache/tmp folders and then make is cmod 777 to finally get W3TC to upgrade properly. What a horrible user experience. The developer should fix this. Seems like it’s been a bug for years.

    Thanks, @nickth — I probably should have done that; what I wound up doing was copying the file over from my development site. (To backup: I updated the development site first and had no problems with the W3TC update. Then when I tried to update on the main site, I had problems (see above) and wound up manually deactivating the site by renaming some file names with “zzz” in front of them. After a few hours I realized that a) my site was only showing the cached version (kind of a problem since I had just deactivated that plugin!) and b) the main difference between the dev site and my main site was that my dev site did not have the Cloudflare plugin running.

    So I deactivated the Cloudflare plugin on the main site. Then copied the /cache/tmp folder (actually the whole /cache folder, which was missing entirely) from my dev site, uploaded it to the proper folder, and then renamed everything I had changed, and then activated the W3TC plugin from the wpadmin page… and sure enough it immediately told me I should delete the Cloudflare plugin; that it was not needed with W3TC. (Will have to research to decide which one should go; I agree with you entirely that this is a horrible user experience.)

    ANYWAY: Cloudflare plugin is deactivated, W3TC is running fine (I had to add some code to a .htaccess file though) and my site now seems to be up and running.

    FWIW: I’m not saying that what I did was the RIGHT thing, but in case it’s useful to anyone else desperately Googling and trying to fix their site, I thought I’d record my experience here.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘After W3 Total Cache plugin update actions generates 500 Internal Server error’ is closed to new replies.