Support » Plugins and Hacks » Intuitive Custom Post Order » After upgrading it works but I get an Error message

  • Resolved larese

    (@larese)


    After upgrading to newest version, I got this message on Posts and pages manin pages in the dashboard:

    Warning: Missing argument 2 for hicpo_edit_post_per_page() in /web/htdocs/www.giorgiomirto.com/home/wp-content/plugins/intuitive-custom-post-order/intuitive-custom-post-order.php on line 87

    Warning: Missing argument 2 for hicpo_edit_post_per_page() in /web/htdocs/www.giorgiomirto.com/home/wp-content/plugins/intuitive-custom-post-order/intuitive-custom-post-order.php on line 87

    Any ideas to remove it?
    Thanx
    Luca

    http://wordpress.org/extend/plugins/intuitive-custom-post-order/

Viewing 10 replies - 1 through 10 (of 10 total)
  • This is the code /***************************************************************

    edit posts per page hook

    ***************************************************************/

    add_filter( ‘edit_posts_per_page’, ‘hicpo_edit_post_per_page’ );
    function hicpo_edit_post_per_page( $per_page, $post_type ) {

    $post_list_url = substr($_SERVER[“REQUEST_URI”], -18, 18);
    if ( (isset($_GET[‘post_type’]) && $_GET[‘post_type’] != ‘page’) || $post_list_url == ‘/wp-admin/edit.php’ ) {
    $per_page = 999;
    }

    return $per_page;
    }

    larese, i i keep getting the error.
    wordpress 3.4.2
    P.S.:By the way, plugin seems to works

    Same here.
    Got that error message.
    By the way plugin seems to work fine.

    Can i download the older version?

    Dittos, same error for me too.

    I have the same error and the plugin is not working at all, after last upgrade. Hope the author to reply soon!

    Plugin Author hijiri

    (@hijiri)


    I’m the author of Intuitive Custom Post Order.
    I apologize that error message.
    I upgraded 1.1.1. Please try this.

    I do the effort which corresponds directly.

    Hi hijiri! with the last update (1.1.1) everything is running smooth again! Thanks for you precious code and your quick support!

    There was an update the corrected the trouble. All is running great again.

    It’s all ok for me too. I downloaded the last upgrade directly from wordpress.org, deleted the plugin folder in my ftp and uploaded new unzipped folder. And then all worked perfectly again. Thanks!

    Thank you very much for the upgrade, also for me the problem is solved, no more error message !

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘After upgrading it works but I get an Error message’ is closed to new replies.